DragonFly On-Line Manual Pages
Compose(5) DragonFly File Formats Manual Compose(5)
Compose - X client mappings for multi-key input sequences
The X library, libX11, provides a simple input method for characters
beyond those represented on typical keyboards using sequences of key
strokes that are combined to enter a single character.
The compose file is searched for in the following order:
- If the environment variable $XCOMPOSEFILE is set, its value is
used as the name of the Compose file.
- If the user's home directory has a file named .XCompose, it is
used as the Compose file.
- The system provided compose file is used by mapping the locale
to a compose file from the list in
Compose files can use an "include" instruction. This allows local
modifications to be made to existing compose files without including
all of the content directly. For example, the system's iso8859-1
compose file can be included with a line like this:
There are several substitutions that can be made in the file name of
the include instruction:
%H expands to the user's home directory (the $HOME environment
%L expands to the name of the locale specific Compose file (i.e.,
%S expands to the name of the system directory for Compose files
For example, you can include in your compose file the default Compose
file by using:
and then rewrite only the few rules that you need to change. New
compose rules can be added, and previous ones replaced.
Compose files are plain text files, with a separate line for each
compose sequence. Comments begin with # characters. Each compose
sequence specifies one or more events and a resulting input sequence,
with an optional comment at the end of the line:
EVENT [EVENT...] : RESULT [# COMMENT]
Each event consists of a specified input keysym, and optional modifier
[([!] ([~] MODIFIER)...) | None] <keysym>
If the modifier list is preceded by "!" it must match exactly.
MODIFIER may be one of Ctrl, Lock, Caps, Shift, Alt or Meta. Each
modifier may be preceded by a "~" character to indicate that the
modifier must not be present. If "None" is specified, no modifier may
The result specifies a string, keysym, or both, that the X client
receives as input when the sequence of events is input:
"STRING" | keysym | "STRING" keysym
Keysyms are specified without the XK_ prefix.
Strings may be direct text encoded in the locale for which the compose
file is to be used, or an escaped octal or hexadecimal character code.
Octal codes are specified as "\123" and hexadecimal codes as "\x3a".
It is not necessary to specify in the right part of a rule a locale
encoded string in addition to the keysym name. If the string is
omitted, Xlib figures it out from the keysym according to the current
locale. I.e., if a rule looks like:
<dead_grave> <A> : "\300" Agrave
the result of the composition is always the letter with the "\300"
code. But if the rule is:
<dead_grave> <A> : Agrave
the result depends on how Agrave is mapped in the current locale.
File to use for compose sequences.
Directory to use for caching compiled compose files.
User default compose file if XCOMPOSEFILE is not set.
File listing the compose file path to use for each locale.
System default compose file for the locale, mapped via
System-wide cache directory for compiled compose files.
Per-user cache directory for compiled compose files.
XLookupString(3), XmbLookupString(3), XwcLookupString(3),
Xutf8LookupString(3), mkcomposecache(1), locale(7).
Xlib - C Language X Interface
X Version 11 libX11 1.6.8 Compose(5)