DragonFly On-Line Manual Pages
SYSCALL_MODULE(9) DragonFly Kernel Developer's Manual SYSCALL_MODULE(9)
NAME
SYSCALL_MODULE -- syscall kernel module declaration macro
SYNOPSIS
#include <sys/proc.h>
#include <sys/module.h>
#include <sys/sysent.h>
SYSCALL_MODULE(name, int *offset, struct sysent new_sysent,
modeventhand_t evh, void *arg);
DESCRIPTION
The SYSCALL_MODULE() macro declares a new syscall. SYSCALL_MODULE()
expands into a kernel module declaration named as name.
offset is a pointer to an int which saves the offset in struct sysent
where the syscall is allocated.
new_sysent specifies the function implementing the syscall and the number
of arguments this function needs (see <sys/sysent.h>).
evh is a pointer to the kernel module event handler function with the
argument arg. Please refer to module(9) for more information.
EXAMPLES
A minimal example for a syscall module can be found in
/usr/share/examples/kld/syscall/module/syscall.c.
SEE ALSO
module(9)
/usr/share/examples/kld/syscall/module/syscall.c
AUTHORS
This manual page was written by Alexander Langer <alex@FreeBSD.org>.
DragonFly 3.5 April 27, 2001 DragonFly 3.5