DragonFly On-Line Manual Pages
VFS_MOUNT(9) DragonFly Kernel Developer's Manual VFS_MOUNT(9)
NAME
VFS_MOUNT -- mount a filesystem
SYNOPSIS
#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>
int
VFS_MOUNT(struct mount *mp, char *path, caddr_t data,
struct ucred *cred);
DESCRIPTION
Mount a filesystem into the system's namespace.
Its arguments are:
mp Structure representing the filesystem.
path Pathname where the filesystem is being mounted.
data Filesystem specific data. This should be read into the kernel
using copyin(9).
cred Pointer to a struct ucred for user credentials checking.
This is called both to mount new filesystems and to change the attributes
of an existing filesystem. If the MNT_UPDATE flag is set in mp->mnt_flag
then the filesystem should update its internal state from the value of
mp->mnt_flag. This can be used, for instance, to convert a read-only
filesystem to read-write. It is also used by mountd(8) to update the NFS
export information for the filesystem.
If the MNT_UPDATE flag is not specified, then this is a newly mounted
filesystem. The filesystem code should allocate and initialize any pri-
vate data needed to represent the filesystem (it can use the mp->mnt_data
field to store this information).
SEE ALSO
VFS(9), vnode(9)
AUTHORS
This man page was written by Doug Rabson.
DragonFly 3.5 December 16, 2012 DragonFly 3.5