DragonFly On-Line Manual Pages
VFS_STATFS(9) DragonFly Kernel Developer's Manual VFS_STATFS(9)
NAME
VFS_STATFS -- return filesystem status
SYNOPSIS
#include <sys/param.h>
#include <sys/mount.h>
#include <sys/vnode.h>
int
VFS_STATFS(struct mount *mp, struct statfs *sbp, struct ucred *cred);
DESCRIPTION
This call returns various pieces of information about the filesystem,
including recommended I/O sizes, free space, free inodes, etc.
Its arguments are:
mp The filesystem.
sbp Return parameter for the filesystem's status.
cred
Credentials for the process which is querying the filesystem.
SEE ALSO
VFS(9), vnode(9)
AUTHORS
This man page was written by Doug Rabson.
DragonFly 3.5 September 1, 2011 DragonFly 3.5