DragonFly On-Line Manual Pages
AMR(4) DragonFly Kernel Interfaces Manual AMR(4)
NAME
amr -- MegaRAID SCSI/ATA/SATA RAID driver
SYNOPSIS
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
device pci
device scbus
device amr
To compile in debugging code:
options AMR_DEBUG=x # x=3 is maximum verbosity
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
amr_load="YES"
DESCRIPTION
The amr driver provides support for LSI Logic MegaRAID SCSI, ATA and SATA
RAID controllers and legacy American Megatrends MegaRAID SCSI RAID
controllers, including models relabeled and sold by Dell and Hewlett-
Packard.
LSI MegaRAID SAS controllers are supported by mfi(4) and mrsas(4) and
will not work with this driver.
FILES
/dev/amrdX amr device nodes
HARDWARE
Controllers supported by the amr driver include:
o MegaRAID SATA 150-4
o MegaRAID SATA 150-6
o MegaRAID SATA 300-4X
o MegaRAID SATA 300-8X
o MegaRAID SCSI 320-1E
o MegaRAID SCSI 320-2E
o MegaRAID SCSI 320-4E
o MegaRAID SCSI 320-0X
o MegaRAID SCSI 320-2X
o MegaRAID SCSI 320-4X
o MegaRAID SCSI 320-0
o MegaRAID SCSI 320-1
o MegaRAID SCSI 320-2
o MegaRAID SCSI 320-4
o MegaRAID Series 418
o MegaRAID i4 133 RAID
o MegaRAID Elite 1500 (Series 467)
o MegaRAID Elite 1600 (Series 493)
o MegaRAID Elite 1650 (Series 4xx)
o MegaRAID Enterprise 1200 (Series 428)
o MegaRAID Enterprise 1300 (Series 434)
o MegaRAID Enterprise 1400 (Series 438)
o MegaRAID Enterprise 1500 (Series 467)
o MegaRAID Enterprise 1600 (Series 471)
o MegaRAID Express 100 (Series 466WS)
o MegaRAID Express 200 (Series 466)
o MegaRAID Express 300 (Series 490)
o MegaRAID Express 500 (Series 475)
o Dell PERC
o Dell PERC 2/SC
o Dell PERC 2/DC
o Dell PERC 3/DCL
o Dell PERC 3/QC
o Dell PERC 4/DC
o Dell PERC 4/IM
o Dell PERC 4/SC
o Dell PERC 4/Di
o Dell PERC 4e/DC
o Dell PERC 4e/Di
o Dell PERC 4e/Si
o Dell PERC 4ei
o HP NetRAID-1/Si
o HP NetRAID-3/Si (D4943A)
o HP Embedded NetRAID
o Intel RAID Controller SRCS16
o Intel RAID Controller SRCU42X
DIAGNOSTICS
Compiling with AAC_DEBUG will enable debug messages.
Driver initialisation/shutdown phase
amr%d: memory window not available
amr%d: I/O window not available
The PCI BIOS did not allocate resources necessary for the correct
operation of the controller. The driver cannot attach to this
controller.
amr%d: busmaster bit not set, enabling
The PCI BIOS did not enable busmaster DMA, which is required for the
correct operation of the controller. The driver has enabled this bit and
initialisation will proceed.
amr%d: can't allocate register window
amr%d: can't allocate interrupt
amr%d: can't set up interrupt
amr%d: can't allocate parent DMA tag
amr%d: can't allocate buffer DMA tag
amr%d: can't allocate scatter/gather DMA tag
amr%d: can't allocate s/g table
amr%d: can't allocate mailbox tag
amr%d: can't allocate mailbox memory
A resource allocation error occurred while initialising the driver;
initialisation has failed and the driver will not attach to this
controller.
amr%d: can't obtain configuration data from controller
amr%d: can't obtain product data from controller
The driver was unable to obtain vital configuration data from the
controller. Initialisation has failed and the driver will not attach to
this controller.
amr%d: can't establish configuration hook
amr%d: can't scan controller for drives
The scan for logical drives managed by the controller failed. No drives
will be attached.
amr%d: device_add_child failed
amr%d: bus_generic_attach returned %d
Creation of the logical drive instances failed; attachment of one or more
logical drives may have been aborted.
amr%d: flushing cache...
The controller cache is being flushed prior to shutdown or detach.
Operational diagnostics
amr%d: I/O beyond end of unit (%u,%d > %u)
A partitioning error or disk corruption has caused an I/O request beyond
the end of the logical drive. This may also occur if FlexRAID Virtual
Sizing is enabled and an I/O operation is attempted on a portion of the
virtual drive beyond the actual capacity available.
amr%d: polled command timeout
An initialisation command timed out. The initialisation process may fail
as a result.
amr%d: bad slot %d completed
The controller reported completion of a command that the driver did not
issue. This may result in data corruption, and suggests a hardware or
firmware problem with the system or controller.
amr%d: I/O error - %x
An I/O error has occurred.
SEE ALSO
cd(4), da(4), mfi(4), mrsas(4), sa(4), scsi(4)
AUTHORS
The amr driver was written by Mike Smith <msmith@FreeBSD.org>.
This manual page was written by Mike Smith <msmith@FreeBSD.org> and
Jeroen Ruigrok van der Werven <asmodai@FreeBSD.org>.
DragonFly 4.1 December 10, 2014 DragonFly 4.1