DragonFly On-Line Manual Pages

Search: Section:  


ARCHIVE(8)                InterNetNews Documentation                ARCHIVE(8)

NAME

archive - Usenet article archiver

SYNOPSIS

archive [-cfr] [-a archive] [-i index] [-p pattern] [input]

DESCRIPTION

archive makes copies of files specified on its standard input. It is normally run either as a channel feed under innd or by a script before news.daily is run. archive reads the named input file, or standard input if no file is given. The input is taken as a sequence of lines; blank lines and lines starting with a number sign ("#") are ignored. All other lines should specify the token of an article to archive. Every article is retrieved from a token, and the Xref: header is used to determine the target file in the archive directory. You can limit the targets taken from the Xref: header with the -p option. Files are copied to a directory within the archive directory, patharchive in inn.conf (or some other directory given with -a). The default is to create a hierarchy that mimics a traditional news spool storage of the given articles; intermediate directories will be created as needed. For example, if the input token represents article 2211 in the newsgroup comp.sources.unix, archive will by default store the article as: comp/sources/unix/2211 in the archive area. This can be modified with the -c and -f options.

OPTIONS

-a archive If the -a flag is given, its argument specifies the root of the archive area, instead of patharchive in inn.conf. -c If the -c flag is given, directory names will be flattened as described under the -f option. Then, additionally, all posts will be concatenated into a single file, appending to that file if it already exists. The file name will be "YYYYMM", formed from the current time when archive is run. In other words, if given an article in comp.sources.unix on December 14th, 1998, the article would be appended to the file: comp.sources.unix/199812 in the archive area. Articles will be separated by a line containing only "-----------". -f If the -f flag is used, directory names will be flattened, replacing the slashes with the periods. In other words, article 2211 in comp.sources.unix will be written to: comp.sources.unix/2211 in the archive area. -i index If the -i flag is used, archive will append one line to the file index for each article that it archives. This line will contain the destination file name, the Message-ID: header, and the Subject: header of the message, separated by spaces. If either header is missing (normally not possible if the article was accepted by innd), it will be replaced by "<none>". The headers will be transformed using the same rules as are used to generate overview data (unfolded and then with tabs, CR, and LF replaced by spaces). -p pattern Limits the targets taken from the Xref: header to the groups specified in pattern. pattern is a uwildmat(3) pattern matching newsgroups that you wish to have archive handle. -r By default, archive sets its standard error to pathlog/errlog. To suppress this redirection, use the -r flag.

RETURN VALUE

If the input is exhausted, archive will exit with a zero status. If an I/O error occurs, it will try to spool its input, copying it to a file. If there was no input filename, the standard input will be copied to pathoutgoing/archive and the program will exit. If an input filename was given, a temporary file named input.bch (if input is an absolute pathname) or pathoutgoing/input.bch (if the filename does not begin with a slash) is created. Once the input is copied, archive will try to rename this temporary file to be the name of the input file, and then exit.

EXAMPLES

A typical newsfeeds(5) entry to archive most source newsgroups is as follows: source-archive!\ :!*,*sources*,!*wanted*,!*.d\ :Tc,Wn\ :<pathbin>/archive -f -i <patharchive>/INDEX Replace <pathbin> and <patharchive> with the appropriate paths.

HISTORY

Written by Rich $alz <rsalz@uunet.uu.net> for InterNetNews. Converted to POD by Russ Allbery <eagle@eyrie.org>. $Id: archive.pod 9767 2014-12-07 21:13:43Z iulius $

SEE ALSO

inn.conf(5), newsfeeds(5). INN 2.6.0 2015-09-12 ARCHIVE(8) ARCHIVE_ENTRY_PERMS(3) DragonFly Library Functions Manual

NAME

archive_entry_gid, archive_entry_set_gid, archive_entry_uid, archive_entry_set_uid, archive_entry_perm, archive_entry_set_perm, archive_entry_strmode, archive_entry_uname, archive_entry_uname_w, archive_entry_set_uname, archive_entry_copy_uname, archive_entry_copy_uname_w, archive_entry_update_uname_utf8, archive_entry_gname, archive_entry_gname_w, archive_entry_set_gname, archive_entry_copy_gname, archive_entry_copy_gname_w, archive_entry_update_gname_utf8, archive_entry_fflags, archive_entry_fflags_text, archive_entry_set_fflags, archive_entry_copy_fflags_text, archive_entry_copy_fflags_text_w - functions for manipulating ownership and permissions in archive entry descriptions

LIBRARY

Streaming Archive Library (libarchive, -larchive)

SYNOPSIS

#include <archive_entry.h> gid_t archive_entry_gid(struct archive_entry *a); void archive_entry_set_gid(struct archive_entry *a, gid_t gid); uid_t archive_entry_uid(struct archive_entry *a); void archive_entry_set_uid(struct archive_entry *a, uid_t uid); mode_t archive_entry_perm(struct archive_entry *a); void archive_entry_set_perm(struct archive_entry *a, mode_t mode); const char * archive_entry_strmode(struct archive_entry *a); const char * archive_entry_gname(struct archive_entry *a); const wchar_t * archive_entry_gname_w(struct archive_entry *a); void archive_entry_set_gname(struct archive_entry *a, const char *a); void archive_entry_copy_gname(struct archive_entry *a, const char *name); void archive_entry_copy_gname_w(struct archive_entry *a, const wchar_t *name); int archive_entry_update_gname_utf8(struct archive_entry *a, const char *name); const char * archive_entry_uname(struct archive_entry *a); const wchar_t * archive_entry_uname_w(struct archive_entry *a); void archive_entry_set_uname(struct archive_entry *a, const char *name); void archive_entry_copy_uname(struct archive_entry *a, const char *name); void archive_entry_copy_uname_w(struct archive_entry *a, const wchar_t *name); int archive_entry_update_uname_utf8(struct archive_entry *a, const char *name); void archive_entry_fflags(struct archive_entry *a, unsigned long *set_bits, unsigned long *clear_bits); const char * archive_entry_fflags_text(struct archive_entry *a); void archive_entry_set_fflags(struct archive_entry *a, unsigned long set_bits, unsigned long clear_bits); const char * archive_entry_copy_fflags_text(struct archive_entry *a, const char *text); const wchar_t * archive_entry_copy_fflags_text_w(struct archive_entry *a, const wchar_t *text);

DESCRIPTION

User id, group id and mode The functions archive_entry_uid(), archive_entry_gid(), and archive_entry_perm() can be used to extract the user id, group id and permission from the given entry. The corresponding functions archive_entry_set_uid(), archive_entry_set_gid(), and archive_entry_set_perm() store the given user id, group id and permission in the entry. The permission is also set as a side effect of calling archive_entry_set_mode(). archive_entry_strmode() returns a string representation of the permission as used by the long mode of ls(1). User and group name User and group names can be provided in one of three different ways: char * Multibyte strings in the current locale. wchar_t * Wide character strings in the current locale. The accessor functions are named XXX_w(). UTF-8 Unicode strings encoded as UTF-8. These are convenience functions to update both the multibyte and wide character strings at the same time. archive_entry_set_XXX() is an alias for archive_entry_copy_XXX(). File Flags File flags are transparently converted between a bitmap representation and a textual format. For example, if you set the bitmap and ask for text, the library will build a canonical text format. However, if you set a text format and request a text format, you will get back the same text, even if it is ill-formed. If you need to canonicalize a textual flags string, you should first set the text form, then request the bitmap form, then use that to set the bitmap form. Setting the bitmap format will clear the internal text representation and force it to be reconstructed when you next request the text form. The bitmap format consists of two integers, one containing bits that should be set, the other specifying bits that should be cleared. Bits not mentioned in either bitmap will be ignored. Usually, the bitmap of bits to be cleared will be set to zero. In unusual circumstances, you can force a fully-specified set of file flags by setting the bitmap of flags to clear to the complement of the bitmap of flags to set. (This differs from fflagstostr(3), which only includes names for set bits.) Converting a bitmap to a textual string is a platform-specific operation; bits that are not meaningful on the current platform will be ignored. The canonical text format is a comma-separated list of flag names. The archive_entry_copy_fflags_text() and archive_entry_copy_fflags_text_w() functions parse the provided text and set the internal bitmap values. This is a platform-specific operation; names that are not meaningful on the current platform will be ignored. The function returns a pointer to the start of the first name that was not recognized, or NULL if every name was recognized. Note that every name -- including names that follow an unrecognized name -- will be evaluated, and the bitmaps will be set to reflect every name that is recognized. (In particular, this differs from strtofflags(3), which stops parsing at the first unrecognized name.)

SEE ALSO

archive_entry(3), archive_entry_acl(3), archive_read_disk(3), archive_write_disk(3), libarchive(3)

BUGS

The platform types uid_t and gid_t are often 16 or 32 bit wide. In this case it is possible that the ids can not be correctly restored from archives and get truncated. DragonFly 5.9-DEVELOPMENT February 2, 2012 DragonFly 5.9-DEVELOPMENT

Search: Section: