DragonFly On-Line Manual Pages

Search: Section:  


ARCHIVE(8)                InterNetNews Documentation                ARCHIVE(8)

NAME

archive - Usenet article archiver

SYNOPSIS

archive [-cfr] [-a archive] [-i index] [-p pattern] [input]

DESCRIPTION

archive makes copies of files specified on its standard input. It is normally run either as a channel feed under innd or by a script before news.daily is run. archive reads the named input file, or standard input if no file is given. The input is taken as a sequence of lines; blank lines and lines starting with a number sign ("#") are ignored. All other lines should specify the token of an article to archive. Every article is retrieved from a token, and the Xref: header is used to determine the target file in the archive directory. You can limit the targets taken from the Xref: header with the -p option. Files are copied to a directory within the archive directory, patharchive in inn.conf (or some other directory given with -a). The default is to create a hierarchy that mimics a traditional news spool storage of the given articles; intermediate directories will be created as needed. For example, if the input token represents article 2211 in the newsgroup comp.sources.unix, archive will by default store the article as: comp/sources/unix/2211 in the archive area. This can be modified with the -c and -f options.

OPTIONS

-a archive If the -a flag is given, its argument specifies the root of the archive area, instead of patharchive in inn.conf. -c If the -c flag is given, directory names will be flattened as described under the -f option. Then, additionally, all posts will be concatenated into a single file, appending to that file if it already exists. The file name will be "YYYYMM", formed from the current time when archive is run. In other words, if given an article in comp.sources.unix on December 14th, 1998, the article would be appended to the file: comp.sources.unix/199812 in the archive area. Articles will be separated by a line containing only "-----------". -f If the -f flag is used, directory names will be flattened, replacing the slashes with the periods. In other words, article 2211 in comp.sources.unix will be written to: comp.sources.unix/2211 in the archive area. -i index If the -i flag is used, archive will append one line to the file index for each article that it archives. This line will contain the destination file name, the Message-ID: header, and the Subject: header of the message, separated by spaces. If either header is missing (normally not possible if the article was accepted by innd), it will be replaced by "<none>". The headers will be transformed using the same rules as are used to generate overview data (unfolded and then with tabs, CR, and LF replaced by spaces). -p pattern Limits the targets taken from the Xref: header to the groups specified in pattern. pattern is a uwildmat(3) pattern matching newsgroups that you wish to have archive handle. -r By default, archive sets its standard error to pathlog/errlog. To suppress this redirection, use the -r flag.

RETURN VALUE

If the input is exhausted, archive will exit with a zero status. If an I/O error occurs, it will try to spool its input, copying it to a file. If there was no input filename, the standard input will be copied to pathoutgoing/archive and the program will exit. If an input filename was given, a temporary file named input.bch (if input is an absolute pathname) or pathoutgoing/input.bch (if the filename does not begin with a slash) is created. Once the input is copied, archive will try to rename this temporary file to be the name of the input file, and then exit.

EXAMPLES

A typical newsfeeds(5) entry to archive most source newsgroups is as follows: source-archive!\ :!*,*sources*,!*wanted*,!*.d\ :Tc,Wn\ :<pathbin>/archive -f -i <patharchive>/INDEX Replace <pathbin> and <patharchive> with the appropriate paths.

HISTORY

Written by Rich $alz <rsalz@uunet.uu.net> for InterNetNews. Converted to POD by Russ Allbery <eagle@eyrie.org>. $Id: archive.pod 9767 2014-12-07 21:13:43Z iulius $

SEE ALSO

inn.conf(5), newsfeeds(5). INN 2.6.0 2015-09-12 ARCHIVE(8) ARCHIVE_READ_FILTER(3) DragonFly Library Functions Manual

NAME

archive_read_support_filter_all, archive_read_support_filter_bzip2, archive_read_support_filter_compress, archive_read_support_filter_gzip, archive_read_support_filter_lz4, archive_read_support_filter_lzma, archive_read_support_filter_none, archive_read_support_filter_rpm, archive_read_support_filter_uu, archive_read_support_filter_xz, archive_read_support_filter_zstd, archive_read_support_filter_program, archive_read_support_filter_program_signature - functions for reading streaming archives

LIBRARY

Streaming Archive Library (libarchive, -larchive)

SYNOPSIS

#include <archive.h> int archive_read_support_filter_all(struct archive *); int archive_read_support_filter_by_code(struct archive *, int); int archive_read_support_filter_bzip2(struct archive *); int archive_read_support_filter_compress(struct archive *); int archive_read_support_filter_grzip(struct archive *); int archive_read_support_filter_gzip(struct archive *); int archive_read_support_filter_lrzip(struct archive *); int archive_read_support_filter_lz4(struct archive *); int archive_read_support_filter_lzma(struct archive *); int archive_read_support_filter_lzop(struct archive *); int archive_read_support_filter_none(struct archive *); int archive_read_support_filter_rpm(struct archive *); int archive_read_support_filter_uu(struct archive *); int archive_read_support_filter_xz(struct archive *); int archive_read_support_filter_zstd(struct archive *); int archive_read_support_filter_program(struct archive *, const char *cmd); int archive_read_support_filter_program_signature(struct archive *, const char *cmd, const void *signature, size_t signature_length);

DESCRIPTION

archive_read_support_filter_bzip2(), archive_read_support_filter_compress(), archive_read_support_filter_grzip(), archive_read_support_filter_gzip(), archive_read_support_filter_lrzip(), archive_read_support_filter_lz4(), archive_read_support_filter_lzma(), archive_read_support_filter_lzop(), archive_read_support_filter_none(), archive_read_support_filter_rpm(), archive_read_support_filter_uu(), archive_read_support_filter_xz(), archive_read_support_filter_zstd(), Enables auto-detection code and decompression support for the specified compression. These functions may fall back on external programs if an appropriate library was not available at build time. Decompression using an external program is usually slower than decompression through built-in libraries. Note that "none" is always enabled by default. archive_read_support_filter_all() Enables all available decompression filters. archive_read_support_filter_by_code() Enables a single filter specified by the filter code. This function does not work with ARCHIVE_FILTER_PROGRAM. Note: In statically-linked executables, this will cause your program to include support for every filter. If executable size is a concern, you may wish to avoid using this function. archive_read_support_filter_program() Data is fed through the specified external program before being dearchived. Note that this disables automatic detection of the compression format, so it makes no sense to specify this in conjunction with any other decompression option. archive_read_support_filter_program_signature() This feeds data through the specified external program but only if the initial bytes of the data match the specified signature value.

RETURN VALUES

These functions return ARCHIVE_OK if the compression is fully supported, ARCHIVE_WARN if the compression is supported only through an external program. archive_read_support_filter_none() always succeeds.

ERRORS

Detailed error codes and textual descriptions are available from the archive_errno() and archive_error_string() functions.

SEE ALSO

archive_read(3), archive_read_data(3), archive_read_format(3), archive_read_format(3), libarchive(3) DragonFly 6.3-DEVELOPMENT June 9, 2020 DragonFly 6.3-DEVELOPMENT

Search: Section: