DragonFly On-Line Manual Pages
ARP(4) DragonFly Kernel Interfaces Manual ARP(4)
arp -- Address Resolution Protocol
The Address Resolution Protocol (ARP) is used to dynamically map between
Protocol Addresses (such as IP addresses) and Local Network Addresses
(such as Ethernet addresses). This implementation maps IP addresses to
Ethernet, ARCnet, or Token Ring addresses. It is used by all the Ether-
net interface drivers.
ARP caches Internet-Ethernet address mappings. When an interface
requests a mapping for an address not in the cache, ARP queues the mes-
sage which requires the mapping and broadcasts a message on the associ-
ated network requesting the address mapping. If a response is provided,
the new mapping is cached and any pending message is transmitted. ARP
will queue at most one packet while waiting for a response to a mapping
request; only the most recently ``transmitted'' packet is kept. If the
target host does not respond after several requests, the host is consid-
ered to be down for a short period (normally 20 seconds), allowing an
error to be returned to transmission attempts during this interval. The
error is EHOSTDOWN for a non-responding destination host, and
EHOSTUNREACH for a non-responding router.
The ARP cache is stored in the system routing table as dynamically-cre-
ated host routes. The route to a directly-attached Ethernet network is
installed as a ``cloning'' route (one with the RTF_CLONING flag set),
causing routes to individual hosts on that network to be created on
demand. These routes time out periodically (normally 20 minutes after
validated; entries are not validated when not in use). An entry for a
host which is not responding is a ``reject'' route (one with the
RTF_REJECT flag set).
ARP entries may be added, deleted or changed with the arp(8) utility.
Manually-added entries may be temporary or permanent, and may be
``published'', in which case the system will respond to ARP requests for
that host as if it were the target of the request.
In the past, ARP was used to negotiate the use of a trailer encapsula-
tion. This is no longer supported.
ARP watches passively for hosts impersonating the local host (i.e. a host
which responds to an ARP mapping request for the local host's address).
arp: %x:%x:%x:%x:%x:%x is using my IP address %d.%d.%d.%d!: ARP has dis-
covered another host on the local network which responds to mapping
requests for its own Internet address with a different Ethernet address,
generally indicating that two hosts are attempting to use the same Inter-
arp: ether address is broadcast for IP address %d.%d.%d.%d!: ARP
requested information for a host, and received an answer indicating that
the host's ethernet address is the ethernet broadcast address. This
indicates a misconfigured or broken device.
arp: %d.%d.%d.%d moved from %x:%x:%x:%x:%x:%x to %x:%x:%x:%x:%x:%x: ARP
had a cached value for the ethernet address of the referenced host, but
received a reply indicating that the host is at a new address. This can
happen normally when host hardware addresses change, or when a mobile
node arrives or leaves the local subnet. It can also indicate a problem
with proxy ARP.
arpresolve: can't allocate llinfo for %d.%d.%d.%d: The route for the ref-
erenced host points to a device upon which ARP is required, but ARP was
unable to allocate a routing table entry in which to store the host's MAC
address. This usually points to a misconfigured routing table. It can
also occur if the kernel cannot allocate memory.
inet(4), route(4), arp(8), ifconfig(8), route(8)
Plummer, D., "RFC 826", An Ethernet Address Resolution Protocol.
Leffler, S.J. and Karels, M.J., "RFC 893", Trailer Encapsulations.
DragonFly 3.5 April 18, 1994 DragonFly 3.5