DragonFly On-Line Manual Pages
AUTOFS(5) DragonFly File Formats Manual AUTOFS(5)
autofs - automounter filesystem
To compile this driver into the kernel, place the following line in the
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The autofs driver is the kernel component of the automounter
infrastructure. Its job is to pass mount requests to the automountd(8)
daemon, and pause the processes trying to access the automounted
filesystem until the mount is completed. It is mounted by the
These options are available when mounting autofs file systems:
Mount options for all filesystems specified in the map entry.
Filesystem mountpoint prefix.
To unmount all mounted autofs filesystems:
umount -At autofs
To mount autofs filesystems specified in auto_master(5):
auto_master(5), automount(8), automountd(8), autounmountd(8)
The autofs driver first appeared in FreeBSD 10.1. The autofs driver
first appeared in DragonFly 4.5.
The autofs was developed by Edward Tomasz Napierala <trasz@FreeBSD.org>
under sponsorship from the FreeBSD Foundation.
The autofs was ported to DragonFly by
Tomohiro Kusumi <email@example.com>. Donated to DragonFlyBSD by
PeerCorps Trust Fund.
The autofs driver on DragonFly currently does't support
vfs.autofs.mount_on_stat sysctl. This sysctl is disabled by default on
both FreeBSD and DragonFly, but enabling it does nothing on DragonFly.
DragonFly 5.7-DEVELOPMENT April 14, 2016 DragonFly 5.7-DEVELOPMENT