DragonFly On-Line Manual Pages
DISKLABEL32(5) DragonFly File Formats Manual DISKLABEL32(5)
NAME
disklabel32 -- 32 bit disk pack label
SYNOPSIS
#include <sys/disklabel.h>
DESCRIPTION
Each disk or disk pack on a system may contain a disk label which
provides detailed information about the geometry of the disk and the
partitions into which the disk is divided. It should be initialized when
the disk is formatted, and may be changed later with the disklabel32(8)
program. This information is used by the system disk driver and by the
bootstrap program to determine how to program the drive and where to find
the file systems on the disk partitions. Additional information is used
by the file system in order to use the disk most efficiently and to
locate important file system information. The description of each
partition contains an identifier for the partition type (standard file
system, swap area, etc.). The file system updates the in-core copy of
the label if it contains incomplete information about the file system.
The label is located in sector number LABELSECTOR of the drive, usually
sector 0 where it may be found without any information about the disk
geometry. It is at an offset LABELOFFSET from the beginning of the
sector, to allow room for the initial bootstrap. The disk sector
containing the label is normally made read-only so that it is not
accidentally overwritten by pack-to-pack copies or swap operations; the
DIOCWLABEL ioctl(2), which is done as needed by the disklabel32(8)
program.
A copy of the in-core label for a disk can be obtained with the
DIOCGDINFO ioctl(2); this works with a file descriptor for a block or
character (``raw'') device for any partition of the disk. The in-core
copy of the label is set by the DIOCSDINFO ioctl(2). The offset of a
partition cannot generally be changed while it is open, nor can it be
made smaller while it is open. One exception is that any change is
allowed if no label was found on the disk, and the driver was able to
construct only a skeletal label without partition information. Finally,
the DIOCWDINFO ioctl(2) operation sets the in-core label and then updates
the on-disk label; there must be an existing label on the disk for this
operation to succeed. Thus, the initial label for a disk or disk pack
must be installed by writing to the raw disk. All of these operations
are normally done using disklabel32(8).
The format of the disk label is specified in <sys/disklabel32.h>.
SEE ALSO
disklabel64(5), disktab(5), disklabel32(8)
DragonFly 4.3 August 21, 2008 DragonFly 4.3