DragonFly On-Line Manual Pages

Search: Section:  


ERROR(8)               DragonFly System Manager's Manual              ERROR(8)

NAME

error - Postfix error/retry mail delivery agent

SYNOPSIS

error [generic Postfix daemon options]

DESCRIPTION

The Postfix error(8) delivery agent processes delivery requests from the queue manager. Each request specifies a queue file, a sender address, the reason for non-delivery (specified as the next-hop destination), and recipient information. The reason may be prefixed with an RFC 3463-compatible detail code; if none is specified a default 4.0.0 or 5.0.0 code is used instead. This program expects to be run from the master(8) process manager. Depending on the service name in master.cf, error or retry, the server bounces or defers all recipients in the delivery request using the "next-hop" information as the reason for non-delivery. The retry service name is supported as of Postfix 2.4. Delivery status reports are sent to the bounce(8), defer(8) or trace(8) daemon as appropriate.

SECURITY

The error(8) mailer is not security-sensitive. It does not talk to the network, and can be run chrooted at fixed low privilege.

STANDARDS

RFC 3463 (Enhanced Status Codes)

DIAGNOSTICS

Problems and transactions are logged to syslogd(8) or postlogd(8). Depending on the setting of the notify_classes parameter, the postmaster is notified of bounces and of other trouble.

CONFIGURATION PARAMETERS

Changes to main.cf are picked up automatically as error(8) processes run for only a limited amount of time. Use the command "postfix reload" to speed up a change. The text below provides only a parameter summary. See postconf(5) for more details including examples. 2bounce_notice_recipient (postmaster) The recipient of undeliverable mail that cannot be returned to the sender. bounce_notice_recipient (postmaster) The recipient of postmaster notifications with the message headers of mail that Postfix did not deliver and of SMTP conversation transcripts of mail that Postfix did not receive. config_directory (see 'postconf -d' output) The default location of the Postfix main.cf and master.cf configuration files. daemon_timeout (18000s) How much time a Postfix daemon process may take to handle a request before it is terminated by a built-in watchdog timer. delay_logging_resolution_limit (2) The maximal number of digits after the decimal point when logging sub-second delay values. double_bounce_sender (double-bounce) The sender address of postmaster notifications that are generated by the mail system. ipc_timeout (3600s) The time limit for sending or receiving information over an internal communication channel. max_idle (100s) The maximum amount of time that an idle Postfix daemon process waits for an incoming connection before terminating voluntarily. max_use (100) The maximal number of incoming connections that a Postfix daemon process will service before terminating voluntarily. notify_classes (resource, software) The list of error classes that are reported to the postmaster. process_id (read-only) The process ID of a Postfix command or daemon process. process_name (read-only) The process name of a Postfix command or daemon process. queue_directory (see 'postconf -d' output) The location of the Postfix top-level queue directory. syslog_facility (mail) The syslog facility of Postfix logging. syslog_name (see 'postconf -d' output) A prefix that is prepended to the process name in syslog records, so that, for example, "smtpd" becomes "prefix/smtpd". Available in Postfix 3.3 and later: service_name (read-only) The master.cf service name of a Postfix daemon process.

SEE ALSO

qmgr(8), queue manager bounce(8), delivery status reports discard(8), Postfix discard delivery agent postconf(5), configuration parameters master(5), generic daemon options master(8), process manager postlogd(8), Postfix logging syslogd(8), system logging

LICENSE

The Secure Mailer license must be distributed with this software. AUTHOR(S) Wietse Venema IBM T.J. Watson Research P.O. Box 704 Yorktown Heights, NY 10598, USA Wietse Venema Google, Inc. 111 8th Avenue New York, NY 10011, USA ERROR(8) error(n) Tcl Built-In Commands error(n) ______________________________________________________________________________

NAME

error - Generate an error

SYNOPSIS

error message ?info? ?code? ______________________________________________________________________________

DESCRIPTION

Returns a TCL_ERROR code, which causes command interpretation to be unwound. Message is a string that is returned to the application to indicate what went wrong. The -errorinfo return option of an interpreter is used to accumulate a stack trace of what was in progress when an error occurred; as nested commands unwind, the Tcl interpreter adds information to the -errorinfo return option. If the info argument is present, it is used to initialize the -errorinfo return options and the first increment of unwind information will not be added by the Tcl interpreter. In other words, the command containing the error command will not appear in the stack trace; in its place will be info. Historically, this feature had been most useful in conjunction with the catch command: if a caught error cannot be handled successfully, info can be used to return a stack trace reflecting the original point of occurrence of the error: catch {...} errMsg set savedInfo $::errorInfo ... error $errMsg $savedInfo When working with Tcl 8.5 or later, the following code should be used instead: catch {...} errMsg options ... return -options $options $errMsg If the code argument is present, then its value is stored in the -errorcode return option. The -errorcode return option is intended to hold a machine-readable description of the error in cases where such information is available; see the return manual page for information on the proper format for this option's value.

EXAMPLE

Generate an error if a basic mathematical operation fails: if {1+2 != 3} { error "something is very wrong with addition" }

SEE ALSO

catch(n), return(n)

KEYWORDS

error, exception Tcl error(n)

Search: Section: