DragonFly On-Line Manual Pages

Search: Section:  


IASL(8)                DragonFly System Manager's Manual               IASL(8)

NAME

iasl - ACPI Source Language compiler, ACPI table compiler, and AML disassembler

SYNOPSIS

iasl [option ...] [file ...]

DESCRIPTION

The following options are supported: -@ file Specify command file. -ar Enable reference typechecking. -bc Create converter debug file (*.cdb). -bf Create debug file (full tree only) (*.txt). -bp depth Prune ASL parse tree. -bs Create debug file (parse tree only) (*.txt). -bt type Object type to be pruned from the parse tree. -ca Convert legacy-ASL source file to new ASL+ file (Original comments are passed through to ASL+ file). -cr Disable Resource Descriptor error checking. -d file1 [file2] Disassemble or decode binary ACPI tables to file (*.dsl). The file2 is optional, file type is automatically detected. -D symbol Define symbol for preprocessor use. -da file ... Disassemble multiple tables from single namespace. -db Do not translate Buffers to Resource Templates. -dc file ... Disassemble AML and immediately compile it. Obtain the DSDT from the current system if no input file has it. -df Force the disassembler to assume the table contains valid AML. -dl Emit legacy ASL code only (no C-style operators). -dv Set verbose option. -e file ... Include ACPI table(s) for external symbol resolution. -f Ignore errors, force creation of AML output file(s). -fe file Specify external symbol declaration file. -G Compile custom table that contains generic operators. -h Display the help message. -hc Display operators allowed in constant expressions. -hd Info for obtaining and disassembling binary ACPI tables. -hf Display help for output filename generation. -hr Display ACPI reserved method names. -ht Display currently supported ACPI table names. -I directory Specify additional include directory. -ia Create include file in assembler (*.inc). -ic Create include file in C (*.h). -in When disassembling, ignore NoOp opcodes. When compiling, ignore NoOp operators. -l When compiling, create mixed listing file (ASL source and AML) (*.lst). When disassembling, disassemble to mixed ASL and AML code. -li Create preprocessed output file (*.i). -lm Create hardware summary map file (*.map). -ln Create namespace file (*.nsp). -ls Create combined source file (expanded includes) (*.src). -lx Create cross-reference file (*.xrf). -m size Set internal line buffer size (in Kbytes). -n Parse only, no output generation. -oa Disable all optimizations (compatibility mode). -oc Display compile times and statistics. -od Disable disassembler code optimizations. -of Disable constant folding. -oi Disable integer optimization to Zero/One/Ones. -on Disable named reference string optimization. -ot Disable typechecking. -P Preprocess only and create preprocessor output file (*.i). -p prefix Specify path/filename prefix for all output files. -Pn Disable preprocessor. -r revision Override table header Revision (1-255). -sa Create source file in assembler (*.asm). -sc Create source file in C (*.c). -so Create offset table in C (*.offset.h). -T sig ... | ALL Create ACPI table template/example files. -T count Emit DSDT and count SSDTs to same file. -ta Create hex AML table in assembler (*.hex). -tc Create hex AML table in C (*.hex). -tp Compile tables with flex/bison prototype. -ts Create hex AML table in ASL (*.hex). -v Display compiler version. -va Disable all errors/warnings/remarks. -vd Display compiler build date and time. -ve Report only errors (ignore warnings and remarks). -vi Less verbose errors and warnings for use with IDEs. -vo Enable optimization comments. -vr Disable remarks. -vs Disable signon. -vt Create verbose template files (full disassembly). -vt Dump binary table data in hex format within output file. -vw message_id Ignore specific error, warning or remark. -vx message_id Expect a specific warning, remark, or error. -w 1 | 2 | 3 Set warning reporting level. -we Report warnings as errors. -ww messageid Report a specific warning or remark as error. -x level Set debug level for trace output. -z Do not insert new compiler ID for DataTables.

SEE ALSO

acpi(4), acpibin(8), acpicall(8), acpiconf(8), acpidump(8), acpiexec(8), acpihelp(8), acpixtract(8) https://acpica.org/documentation/ https://acpica.org/sites/acpica/files/aslcompiler_9.pdf

AUTHORS

The iasl utility is provided by Intel as part of their ACPICA distribution. This manual page was written by Sascha Wildner. DragonFly 5.9-DEVELOPMENT May 29, 2020 DragonFly 5.9-DEVELOPMENT

Search: Section: