DragonFly On-Line Manual Pages
KCOLLECT(8) DragonFly System Manager's Manual KCOLLECT(8)
kcollect - extract kernel-collected statistics
kcollect [-o fields] [-O format] [-b file] [-d file] [-r file] [-f] [-F]
[-l] [-g] [-s] [-t time] [-G] [-W width] [-H height]
[-w plotfile] [-x gnuplot_options]
The kcollect utility extracts regularly collected statistics accumulated
by the kernel. The kernel typically keeps around 23 hours worth of
statistics. If no specific output option is specified, a human-readable
text dump of the accumulated statistics will be output starting with the
most recent collection and then going back in time.
The following options are available:
Indicate which fields to extract. If not specified, all
available fields are extracted. Unknown fields are ignored.
Note that not all commands will filter based on the field list.
You may specify space or comma-separated fieldnames. Whitespace
is ignored. Use the -l option to get a list of available fields.
Specify the desired output format. The following output formats
text This is the default. It produces a human readable text
EXPERIMENTAL. It tries to dump the entries in a InfluxDB
line protocol compatible format.
Dump the data to a dbm database, creating the database if
necessary. Data is indexed by gmt time, which will be calculated
from the ticks. Duplicate tuples are ignored. The database will
retain data from prior runs.
Load the data from a dbm database instead of loading the active
data from the current machine.
This will overwrite headers stored in the specified dbm database
with the in-memory headers. This can be used to renormalize
saved historical dbm files when machine specs change, or if the
dbm is somehow missing the header fields.
-g Generate gnuplot output for the data.
-s Smooth plot output (only applicable to gnuplot). This may make
it more readable. Data is smoothed using an exponential average
over 10 samples (~100 seconds).
Specify the number of seconds worth of recent data to extract.
The 'm', 'h', and 'd' suffixes can be used to specify the value
in minutes, hours, or days.
-x Generate gnuplot output for the data and pipe it to gnuplot for
display to X11.
-l List all available fields and the field format
-f Dump available output then enter a 60-second sleep/collection
loop to incrementally collect and output more data. If
outputting to gnuplot, the plot will be updated regularly.
However, please note that this is fairly expensive since the plot
data has to be completely re-sent to gnuplot on each update.
-F Same as -f but do not display the whole buffer at the beginning.
Generate gnuplot output to a .png or .jpg file, depending on the
extension of the filename you supply.
-G Timestamps for text output will be in GMT instead of localtime.
Set the width and height of the output plot for the plotfile or
for X. The default is 512x512.
The standard kcollect display shows the following statistics:
load system load average
user % of total cpu time in user mode
syst % of total cpu time in system mode
idle % of total cpu time in idle mode
swapuse % of total swap space used
swapano total amount of anonymous swap used in MB
swapcac total amount of swapcache in MB
fault total amount of vm faults including both zero-fill and cow
cow total amount of copy-on-write faults
zfill total amount of zero-fill faults
free amount of free memory in bytes
cache amount of almost free memory in bytes
inact amount of inactive memory in bytes
act amount of active memory in bytes
wired amount of wired/kernel memory in bytes
syscalls total amount of system calls
nlookup total amount of path lookups
intr total amount of nominal external interrupts
ipi total amount of inter-cpu interrupts
timer total amount of timer interrupts
The output fields in bytes are typically converted with
humanize_number(3) before displaying, at least for the default output
A kcollect utility appeared in DragonFly 4.9.
DragonFly 5.7-DEVELOPMENT July 23, 2019 DragonFly 5.7-DEVELOPMENT