DragonFly On-Line Manual Pages

Search: Section:  


MICROUPTIME(9)        DragonFly Kernel Developer's Manual       MICROUPTIME(9)

NAME

microuptime, getmicrouptime, nanouptime, getnanouptime -- get the time elapsed since boot

SYNOPSIS

#include <sys/time.h> void microuptime(struct timeval *tv); void getmicrouptime(struct timeval *tv); void nanouptime(struct timespec *ts); void getnanouptime(struct timespec *tsp);

DESCRIPTION

The microuptime() and getmicrouptime() functions store the time elapsed since boot as a struct timeval at the address specified by tv. The nanouptime() and getnanouptime() functions perform the same utility, but record the elapsed time as a struct timespec instead. Microuptime() and nanouptime() always query the timecounter to return the current time as precisely as possible. Whereas getmicrouptime() and getnanouptime() functions are abstractions which return a less precise, but faster to obtain, time. The getmicrouptime() and getnanouptime() functions will return a time which is up to 1/HZ previous to the call. The intent of the getmicrouptime() and getnanouptime() functions is to enforce the user's preference for timer accuracy versus execution time.

SEE ALSO

getmicrotime(9), getnanotime(9), microtime(9), nanotime(9), tvtohz(9)

AUTHORS

This manual page was written by Kelly Yancey <kbyanc@posi.net>. DragonFly 4.9 September 23, 2017 DragonFly 4.9

Search: Section: