DragonFly On-Line Manual Pages
NG_ONE2MANY(4) DragonFly Kernel Interfaces Manual NG_ONE2MANY(4)
NAME
ng_one2many -- packet multiplexing netgraph node type
SYNOPSIS
#include <netgraph/one2many/ng_one2many.h>
DESCRIPTION
The one2many provides a simple mechanism for routing packets over several
links in a one-to-many (and in the reverse direction, many-to-one) fash-
ion. There is a single hook named one, and multiple hooks named many0,
many1, etc. Packets received on any of the many hooks are forwarded out
the one hook. Packets received on the one hook are forwarded out one of
the many hooks; which hook is determined by the node's configured trans-
mit algorithm. Packets are not altered in any way.
Each of the connected many links may be considered to be up or down.
Packets are never delivered out a many hook that is down. How a link is
determined to be up or down depends on the node's configured link failure
detection algorithm.
TRANSMIT ALGORITHMS
At this time, the only algorithm for determining the outgoing many hook
is a simple round-robin delivery algorithm. Packets are delivered out
the many hooks in sequential order.
In the future other algorithms may be added as well.
LINK FAILURE DETECTION
At this time, the only algorithm for determining when a link has failed,
other than the hook being disconnected, is the ``manual'' algorithm: the
node is explicitly told which of the links are up via the
NGM_ONE2MANY_SET_CONFIG control message (see below). Newly connected
links are down until configured otherwise.
In the future other algorithms may be added as well.
HOOKS
This node type supports up to NG_ONE2MANY_MAX_LINKS hooks named many0,
many1, etc., plus a single hook named one.
CONTROL MESSAGES
This node type supports the generic control messages, plus the following:
NGM_ONE2MANY_SET_CONFIG
Sets the node configuration using a struct ng_one2many_link_config
as the control message argument:
/* Node configuration structure */
struct ng_one2many_config {
u_int32_t xmitAlg; /* how to distribute packets */
u_int32_t failAlg; /* how to detect link failure */
u_char enabledLinks[NG_ONE2MANY_MAX_LINKS];
};
Currently, the only valid setting for the xmitAlg field is
NG_ONE2MANY_XMIT_ROUNDROBIN; this is also the default setting. The
only valid setting for failAlg is NG_ONE2MANY_FAIL_MANUAL; this is
also the default setting.
NGM_ONE2MANY_GET_CONFIG
Returns the current node configuration in a struct
ng_one2many_link_config.
NGM_ONE2MANY_GET_STATS
This command takes a 32 bit link number as an argument and returns a
struct ng_one2many_link_stats containing statistics for the corre-
sponding many link, which may or may not be currently connected:
/* Statistics structure (one for each link) */
struct ng_one2many_link_stats {
u_int64_t recvOctets; /* total octets rec'd on link */
u_int64_t recvPackets; /* total pkts rec'd on link */
u_int64_t xmitOctets; /* total octets xmit'd on link */
u_int64_t xmitPackets; /* total pkts xmit'd on link */
};
To access statistics for the one link, use the link number -1.
NGM_ONE2MANY_CLR_STATS
This command takes a 32 bit link number as an argument and clears
the statistics for that link.
NGM_ONE2MANY_GETCLR_STATS
Same as NGM_ONE2MANY_GET_STATS, but also atomically clears the sta-
tistics for the link as well.
SHUTDOWN
This node shuts down upon receipt of a NGM_SHUTDOWN control message, or
when all hooks have been disconnected.
EXAMPLES
The following commands will set up Ethernet interfaces fxp0 to deliver
packets alternating over the physical interfaces corresponding to net-
working interfaces fxp0 through fxp3:
# Plumb nodes together
ngctl mkpeer fxp0: one2many upper one
ngctl connect fxp0: fxp0:upper lower many0
ngctl connect fxp1: fxp0:upper lower many1
ngctl connect fxp2: fxp0:upper lower many2
ngctl connect fxp3: fxp0:upper lower many3
# Allow fxp1 through fxp3 to xmit/recv fxp0 frames
ngctl msg fxp1: setpromisc 1
ngctl msg fxp2: setpromisc 1
ngctl msg fxp3: setpromisc 1
ngctl msg fxp1: setautosrc 0
ngctl msg fxp2: setautosrc 0
ngctl msg fxp3: setautosrc 0
# Configure all four links as up
ngctl msg fxp0:upper \
setconfig "{ xmitAlg=1 failAlg=1 enabledLinks=[ 1 1 1 1 ] }"
# Bring up interface
ifconfig fxp0 192.168.1.1 netmask 0xfffffffc
With a similar setup on a peer machine (using the address 192.168.1.2), a
point-to-point Ethernet connection with four times normal bandwidth is
achieved.
SEE ALSO
netgraph(4), ng_bridge(4), ng_ether(4), ngctl(8)
HISTORY
The ng_one2many node type was implemented in FreeBSD 4.2.
AUTHORS
Archie Cobbs <archie@FreeBSD.org>
BUGS
More transmit and link failure algorithms should be supported. A good
candidate is Cisco's Etherchannel.
DragonFly 3.5 November 15, 2000 DragonFly 3.5