DragonFly On-Line Manual Pages
SERVICES(5) DragonFly File Formats Manual SERVICES(5)
services -- service name data base
The services file contains information regarding the known services
available in the Internet. For each service a single line should be
present with the following information:
official service name
Items are separated by any number of blanks and/or tab characters. The
port number and protocol name are considered a single item; a ``/'' is
used to separate the port and protocol (e.g. ``512/tcp''). A ``#'' indi-
cates the beginning of a comment; subsequent characters up to the end of
the line are not interpreted by the routines which search the file.
Service names may contain any printable character other than a field
delimiter, newline, or comment character.
Access to the NIS services.byname map can be enabled by adding a single
``+'' on a line by itself in the /etc/services file. This causes the
contents of the NIS services map to be inserted at the location where the
/etc/services The services file resides in /etc.
The services file format appeared in 4.2BSD.
A name server should be used instead of a static file.
DragonFly 3.5 June 5, 1993 DragonFly 3.5