DragonFly On-Line Manual Pages
ACPI_VIDEO(4) DragonFly Kernel Interfaces Manual ACPI_VIDEO(4)
acpi_video -- ACPI Video Extensions driver
This driver uses the ACPI Video Extensions to control display switching
and backlight brightness. The availability of the sysctl(8) variables
depends on the functions offered by the host's ACPI implementation.
The following sysctls are currently implemented, where <device> is crt,
lcd, or tv:
Current state of the output device.
List of supported brightness levels.
Current brightness level of the device.
Preset brightness level to be used in full power mode.
Preset brightness level to be used in economy mode.
Defaults for these variables can be set in sysctl.conf(5), which is
parsed at boot-time.
acpi(4), loader.conf(5), sysctl.conf(5), sysctl(8)
The acpi_video driver first appeared in FreeBSD 5.3 and was imported into
The acpi_video driver was written by Taku YAMAMOTO
<firstname.lastname@example.org>. This manual page was written by Mark
Some systems only perform output switching via SMM even though they
export the proper information via ACPI. On such systems, the proper
hotkeys or OEM driver (for example, acpi_toshiba(4)) must be used
DragonFly 3.7 November 8, 2004 DragonFly 3.7