DragonFly On-Line Manual Pages
ARCHIVE(8) InterNetNews Documentation ARCHIVE(8)
archive - Usenet article archiver
archive [-cfr] [-a archive] [-i index] [-p pattern] [input]
archive makes copies of files specified on its standard input. It is
normally run either as a channel feed under innd or by a script before
news.daily is run.
archive reads the named input file, or standard input if no file is
given. The input is taken as a sequence of lines; blank lines and
lines starting with a number sign ("#") are ignored. All other lines
should specify the token of an article to archive. Every article is
retrieved from a token, and the Xref: header is used to determine the
target file in the archive directory. You can limit the targets taken
from the Xref: header with the -p option.
Files are copied to a directory within the archive directory,
patharchive in inn.conf (or some other directory given with -a). The
default is to create a hierarchy that mimics a traditional news spool
storage of the given articles; intermediate directories will be created
as needed. For example, if the input token represents article 2211 in
the newsgroup comp.sources.unix, archive will by default store the
in the archive area. This can be modified with the -c and -f options.
If the -a flag is given, its argument specifies the root of the
archive area, instead of patharchive in inn.conf.
-c If the -c flag is given, directory names will be flattened as
described under the -f option. Then, additionally, all posts will
be concatenated into a single file, appending to that file if it
already exists. The file name will be "YYYYMM", formed from the
current time when archive is run. In other words, if given an
article in comp.sources.unix on December 14th, 1998, the article
would be appended to the file:
in the archive area.
Articles will be separated by a line containing only "-----------".
-f If the -f flag is used, directory names will be flattened,
replacing the slashes with the periods. In other words, article
2211 in comp.sources.unix will be written to:
in the archive area.
If the -i flag is used, archive will append one line to the file
index for each article that it archives. This line will contain
the destination file name, the Message-ID: header, and the Subject:
header of the message, separated by spaces. If either header is
missing (normally not possible if the article was accepted by
innd), it will be replaced by "<none>". The headers will be
transformed using the same rules as are used to generate overview
data (unfolded and then with tabs, CR, and LF replaced by spaces).
Limits the targets taken from the Xref: header to the groups
specified in pattern. pattern is a uwildmat(3) pattern matching
newsgroups that you wish to have archive handle.
-r By default, archive sets its standard error to pathlog/errlog. To
suppress this redirection, use the -r flag.
If the input is exhausted, archive will exit with a zero status. If an
I/O error occurs, it will try to spool its input, copying it to a file.
If there was no input filename, the standard input will be copied to
pathoutgoing/archive and the program will exit. If an input filename
was given, a temporary file named input.bch (if input is an absolute
pathname) or pathoutgoing/input.bch (if the filename does not begin
with a slash) is created. Once the input is copied, archive will try
to rename this temporary file to be the name of the input file, and
A typical newsfeeds(5) entry to archive most source newsgroups is as
:<pathbin>/archive -f -i <patharchive>/INDEX
Replace <pathbin> and <patharchive> with the appropriate paths.
Written by Rich $alz <email@example.com> for InterNetNews. Converted
to POD by Russ Allbery <firstname.lastname@example.org>.
$Id: archive.pod 9767 2014-12-07 21:13:43Z iulius $
INN 2.6.0 2015-09-12 ARCHIVE(8)
ARCHIVE_ENTRY(3) DragonFly Library Functions Manual ARCHIVE_ENTRY(3)
archive_entry_clear, archive_entry_clone, archive_entry_free,
archive_entry_new - functions for managing archive entry descriptions
Streaming Archive Library (libarchive, -larchive)
struct archive_entry *
archive_entry_clear(struct archive_entry *);
struct archive_entry *
archive_entry_clone(struct archive_entry *);
archive_entry_free(struct archive_entry *);
struct archive_entry *
These functions create and manipulate data objects that represent entries
within an archive. You can think of a struct archive_entry as a heavy-
duty version of struct stat: it includes everything from struct stat plus
associated pathname, textual group and user names, etc. These objects
are used by libarchive(3) to represent the metadata associated with a
particular entry in an archive.
Create and Destroy
There are functions to allocate, destroy, clear, and copy archive_entry
Erases the object, resetting all internal fields to the same
state as a newly-created object. This is provided to allow you
to quickly recycle objects without thrashing the heap.
A deep copy operation; all text fields are duplicated.
Releases the struct archive_entry object.
Allocate and return a blank struct archive_entry object.
Due to high number of functions, the accessor functions can be found in
man pages grouped by the purpose.
archive_entry_acl(3) Access Control List manipulation
archive_entry_paths(3) Path name manipulation
archive_entry_perms(3) User, group and mode manipulation
archive_entry_stat(3) Functions not in the other groups and copying
to/from struct stat.
archive_entry_time(3) Time field manipulation
Most of the functions set or read entries in an object. Such functions
have one of the following forms:
Stores the provided data in the object. In particular, for
strings, the pointer is stored, not the referenced string.
As above, except that the referenced data is copied into the
Returns the specified data. In the case of strings, a const-
qualified pointer to the string is returned.
String data can be set or accessed as wide character strings or normal
char strings. The functions that use wide character strings are suffixed
with _w. Note that these are different representations of the same data:
For example, if you store a narrow string and read the corresponding wide
string, the object will transparently convert formats using the current
locale. Similarly, if you store a wide string and then store a narrow
string for the same data, the previously-set wide string will be
discarded in favor of the new data.
archive_entry_acl(3), archive_entry_paths(3), archive_entry_perms(3),
The libarchive library first appeared in FreeBSD 5.3.
The libarchive library was written by Tim Kientzle <email@example.com>.
DragonFly 5.9-DEVELOPMENT February 2, 2012 DragonFly 5.9-DEVELOPMENT