DragonFly On-Line Manual Pages
ARCHIVE(8) InterNetNews Documentation ARCHIVE(8)
archive - Usenet article archiver
archive [-cfr] [-a archive] [-i index] [-p pattern] [input]
archive makes copies of files specified on its standard input. It is
normally run either as a channel feed under innd or by a script before
news.daily is run.
archive reads the named input file, or standard input if no file is
given. The input is taken as a sequence of lines; blank lines and
lines starting with a number sign ("#") are ignored. All other lines
should specify the token of an article to archive. Every article is
retrieved from a token, and the Xref: header is used to determine the
target file in the archive directory. You can limit the targets taken
from the Xref: header with the -p option.
Files are copied to a directory within the archive directory,
patharchive in inn.conf (or some other directory given with -a). The
default is to create a hierarchy that mimics a traditional news spool
storage of the given articles; intermediate directories will be created
as needed. For example, if the input token represents article 2211 in
the newsgroup comp.sources.unix, archive will by default store the
in the archive area. This can be modified with the -c and -f options.
If the -a flag is given, its argument specifies the root of the
archive area, instead of patharchive in inn.conf.
-c If the -c flag is given, directory names will be flattened as
described under the -f option. Then, additionally, all posts will
be concatenated into a single file, appending to that file if it
already exists. The file name will be "YYYYMM", formed from the
current time when archive is run. In other words, if given an
article in comp.sources.unix on December 14th, 1998, the article
would be appended to the file:
in the archive area.
Articles will be separated by a line containing only "-----------".
-f If the -f flag is used, directory names will be flattened,
replacing the slashes with the periods. In other words, article
2211 in comp.sources.unix will be written to:
in the archive area.
If the -i flag is used, archive will append one line to the file
index for each article that it archives. This line will contain
the destination file name, the Message-ID: header, and the Subject:
header of the message, separated by spaces. If either header is
missing (normally not possible if the article was accepted by
innd), it will be replaced by "<none>". The headers will be
transformed using the same rules as are used to generate overview
data (unfolded and then with tabs, CR, and LF replaced by spaces).
Limits the targets taken from the Xref: header to the groups
specified in pattern. pattern is a uwildmat(3) pattern matching
newsgroups that you wish to have archive handle.
-r By default, archive sets its standard error to pathlog/errlog. To
suppress this redirection, use the -r flag.
If the input is exhausted, archive will exit with a zero status. If an
I/O error occurs, it will try to spool its input, copying it to a file.
If there was no input filename, the standard input will be copied to
pathoutgoing/archive and the program will exit. If an input filename
was given, a temporary file named input.bch (if input is an absolute
pathname) or pathoutgoing/input.bch (if the filename does not begin
with a slash) is created. Once the input is copied, archive will try
to rename this temporary file to be the name of the input file, and
A typical newsfeeds(5) entry to archive most source newsgroups is as
:<pathbin>/archive -f -i <patharchive>/INDEX
Replace <pathbin> and <patharchive> with the appropriate paths.
Written by Rich $alz <email@example.com> for InterNetNews. Converted
to POD by Russ Allbery <firstname.lastname@example.org>.
$Id: archive.pod 9767 2014-12-07 21:13:43Z iulius $
INN 2.6.0 2015-09-12 ARCHIVE(8)
ARCHIVE_ENTRY_LINK... DragonFly Library Functions Manual ARCHIVE_ENTRY_LINK...
archive_entry_linkify -- hardlink resolver functions
Streaming Archive Library (libarchive, -larchive)
struct archive_entry_linkresolver *
archive_entry_linkresolver_set_strategy(struct archive_entry_linkresolver *resolver,
archive_entry_linkresolver_free(struct archive_entry_linkresolver *resolver);
archive_entry_linkify(struct archive_entry_linkresolver *resolver,
struct archive_entry **entry, struct archive_entry **sparse);
Programs that want to create archives have to deal with hardlinks.
Hardlinks are handled in different ways by the archive formats. The
basic strategies are:
1. Ignore hardlinks and store the body for each reference (old cpio,
2. Store the body the first time an inode is seen (ustar, pax).
3. Store the body the last time an inode is seen (new cpio).
The archive_entry_linkresolver functions help by providing a unified
interface and handling the complexity behind the scene.
The archive_entry_linkresolver functions assume that archive_entry
instances have valid nlinks, inode and device values. The inode and
device value is used to match entries. The nlinks value is used to
determined if all references have been found and if the internal refer-
ences can be recycled.
The archive_entry_linkresolver_new() function allocates a new link
resolver. The instance can be freed using
archive_entry_linkresolver_free(). All deferred entries are flushed and
the internal storage is freed.
The archive_entry_linkresolver_set_strategy() function selects the opti-
mal hardlink strategy for the given format. The format code can be
obtained from archive_format(3). The function can be called more than
once, but it is recommended to flush all deferred entries first.
The archive_entry_linkify() function is the core of
archive_entry_linkresolver. The entry() argument points to the
archive_entry that should be written. Depending on the strategy one of
the following actions is taken:
1. For the simple archive formats *entry is left unmodified and *sparse
is set to NULL.
2. For tar like archive formats, *sparse is set to NULL. If *entry is
NULL, no action is taken. If the hardlink count of *entry is larger
than 1 and the file type is a regular file or symbolic link, the
internal list is searched for a matching inode. If such an inode is
found, the link count is decremented and the file size of *entry is
set to 0 to notify that no body should be written. If no such inode
is found, a copy of the entry is added to the internal cache with a
link count reduced by one.
3. For new cpio like archive formats a value for *entry of NULL is used
to flush deferred entries. In that case *entry is set to an arbi-
trary deferred entry and the entry itself is removed from the inter-
nal list. If the internal list is empty, *entry is set to NULL. In
either case, *sparse is set to NULL and the function returns. If
the hardlink count of *entry is one or the file type is a directory
or device, *sparse is set to NULL and no further action is taken.
Otherwise, the internal list is searched for a matching inode. If
such an inode is not found, the entry is added to the internal list,
both *entry and *sparse are set to NULL and the function returns.
If such an inode is found, the link count is decremented. If it
remains larger than one, the existing entry on the internal list is
swapped with *entry after retaining the link count. The existing
entry is returned in *entry. If the link count reached one, the new
entry is also removed from the internal list and returned in
*sparse. Otherwise *sparse is set to NULL.
The general usage is therefore:
1. For each new archive entry, call archive_entry_linkify().
2. Keep in mind that the entries returned may have a size of 0 now.
3. If *entry is not NULL, archive it.
4. If *sparse is not NULL, archive it.
5. After all entries have been written to disk, call
archive_entry_linkify() with *entry set to NULL and archive the
returned entry as long as it is not NULL.
archive_entry_linkresolver_new() returns NULL on malloc(3) failures.
DragonFly 3.5 February 2, 2012 DragonFly 3.5