DragonFly On-Line Manual Pages
ATKBDC(4) DragonFly Kernel Interfaces Manual ATKBDC(4)
atkbdc - the AT keyboard controller interface
device atkbdc0 at isa? port IO_KBD
The keyboard controller atkbdc provides I/O services for the AT keyboard
and PS/2 mouse style pointing devices. This controller is required for
the keyboard driver atkbd and the PS/2 pointing device driver psm.
There can be only one atkbdc device configured in the system.
Kernel Configuration Options
The following kernel configuration options can be used to control the
The keyboard driver atkbd and the pointing device driver psm may
ask the atkbdc driver to reset these devices during the boot
process. It sometimes takes a long time before these devices
respond to the reset command. These options control how long the
atkbdc driver should wait before eventually giving up -- the
driver will wait X * Y msecs at most. If the drivers seem unable
to detect devices, you may want to increase these values. The
default values are 200 msec for X and 5 for Y.
Sets the debug level to N. The default value is zero, which
suppresses all debugging output.
The atkbdc driver first appeared in FreeBSD 3.1. It is based on the
kbdio module in FreeBSD 2.2.
The kbdio module, the atkbdc driver and this manual page were written by
Kazutaka Yokota <yokota@FreeBSD.org>.
DragonFly 5.7-DEVELOPMENT February 9, 1999 DragonFly 5.7-DEVELOPMENT