DragonFly On-Line Manual Pages
AUTOFS(5) DragonFly File Formats Manual AUTOFS(5)
autofs - automounter filesystem
To compile this driver into the kernel, place the following line in the
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The autofs driver is the kernel component of the automounter
infrastructure. Its job is to pass mount requests to the automountd(8)
daemon, and pause the processes trying to access the automounted
filesystem until the mount is completed. It is mounted by the
These options are available when mounting autofs file systems:
Mount options for all filesystems specified in the map entry.
Filesystem mountpoint prefix.
The following variables are available as both sysctl(8) variables and
Verbosity level for log messages from the autofs driver. Set to
0 to disable logging or 1 to warn about potential problems.
Larger values enable debugging output. Defaults to 1.
Set to 1 to allow mount requests to be interrupted by signal.
Defaults to 1.
Number of seconds before retrying mount requests. Defaults to 1.
Number of attempts before failing mount. Defaults to 3.
Number of seconds to wait before reinvoking automountd(8) for any
given file or directory. Defaults to 600.
Number of seconds to wait for automountd(8) to handle the mount
request. Defaults to 30.
To unmount all mounted autofs filesystems:
umount -At autofs
To mount autofs filesystems specified in auto_master(5):
auto_master(5), automount(8), automountd(8), autounmountd(8)
The autofs driver first appeared in FreeBSD 10.1. The autofs driver
first appeared in DragonFly 4.5.
The autofs was developed by Edward Tomasz Napierala <trasz@FreeBSD.org>
under sponsorship from the FreeBSD Foundation.
The autofs was ported to DragonFly by
Tomohiro Kusumi <firstname.lastname@example.org>. Donated to DragonFlyBSD by
PeerCorps Trust Fund.
DragonFly 5.9-DEVELOPMENT June 4, 2020 DragonFly 5.9-DEVELOPMENT