DragonFly On-Line Manual Pages
avahi-dnsconfd.action(8) DragonFly System Manager's Manual
avahi-dnsconfd.action - avahi-dnsconfd action script
avahi-dnsconfd.action is the action script that is called whenever a
new unicast DNS server is found or removed by avahi-dnsconfd. The
default script as shipped with avahi patches /etc/resolv.conf to
reflect the changed unicast DNS server configuration.
argv Contains the character "+" if the DNS server is new, "-" when
it shall be removed from the DNS server list.
argv The IP address of the DNS server.
argv Numerical network interface number this DNS server was found
argv Numerical protocol number this DNS server was found on.
(usually 2 for IPv4 and 10 for IPv6)
AVAHI_INTERFACE Contains the textual interface name the corresponds
with argv. (e.g. "eth0")
AVAHI_INTERFACE_DNS_SERVERS Contains a list of all DNS servers that
avahi-dnsconfd found on the interface $AVAHI_INTERFACE, separated by
AVAHI_DNS_SERVERS Contains a list of all DNS server that avahi-dnsconfd
found on all interfaces, separated by spaces.
The Avahi Developers <avahi (at) lists (dot) freedesktop (dot) org>;
Avahi is available from http://avahi.org/
This man page was written using xml2man(1) by Oliver Kurth.
Manuals User avahi-dnsconfd.action(8)