DragonFly On-Line Manual Pages
ERRNO(9) DragonFly Kernel Developer's Manual ERRNO(9)
errno -- kernel internal error numbers
This section provides an overview of the error numbers used internally by
the kernel and indicate neither success nor failure. These error numbers
are not returned to userland code.
Kernel functions that indicate success or failure by means of either 0 or
an errno(2) value sometimes have a need to indicate that ``special''
handling is required at an upper layer or, in the case of ioctl(2)
processing, that ``nothing was wrong but the request was not handled''.
To handle these cases, some negative errno(2) values are defined which
are handled by the kernel before returning a different errno(2) value to
userland or simply zero.
The following is a list of the defined names and their meanings as given
-1 ERESTART Restart syscall. The system call should be restarted. This
typically means that the machine dependent system call trap code
will reposition the process's instruction pointer or program
counter to re-execute the current system call with no other work
-2 EJUSTRETURN Do not modify regs, just return. No more work is required
and the function should just return.
-3 ENOIOCTL Ioctl not handled by this layer. The ioctl(2) was not
handled and should be passed through to another layer.
-4 EMOUNTEXIT Mountpoint released via vfs_start(). Specific to mfs(8).
An errno manual page appeared in Version 6 AT&T UNIX. This errno manual
page appeared in NetBSD 3.0.
DragonFly 5.3 May 16, 2018 DragonFly 5.3