DragonFly On-Line Manual Pages
ERROR(8) DragonFly System Manager's Manual ERROR(8)
error - Postfix error/retry mail delivery agent
error [generic Postfix daemon options]
The Postfix error(8) delivery agent processes delivery requests from
the queue manager. Each request specifies a queue file, a sender
address, the reason for non-delivery (specified as the next-hop
destination), and recipient information. The reason may be prefixed
with an RFC 3463-compatible detail code; if none is specified a default
4.0.0 or 5.0.0 code is used instead. This program expects to be run
from the master(8) process manager.
Depending on the service name in master.cf, error or retry, the server
bounces or defers all recipients in the delivery request using the
"next-hop" information as the reason for non-delivery. The retry
service name is supported as of Postfix 2.4.
Delivery status reports are sent to the bounce(8), defer(8) or trace(8)
daemon as appropriate.
The error(8) mailer is not security-sensitive. It does not talk to the
network, and can be run chrooted at fixed low privilege.
RFC 3463 (Enhanced Status Codes)
Problems and transactions are logged to syslogd(8) or postlogd(8).
Depending on the setting of the notify_classes parameter, the
postmaster is notified of bounces and of other trouble.
Changes to main.cf are picked up automatically as error(8) processes
run for only a limited amount of time. Use the command "postfix reload"
to speed up a change.
The text below provides only a parameter summary. See postconf(5) for
more details including examples.
The recipient of undeliverable mail that cannot be returned to
The recipient of postmaster notifications with the message
headers of mail that Postfix did not deliver and of SMTP
conversation transcripts of mail that Postfix did not receive.
config_directory (see 'postconf -d' output)
The default location of the Postfix main.cf and master.cf
How much time a Postfix daemon process may take to handle a
request before it is terminated by a built-in watchdog timer.
The maximal number of digits after the decimal point when
logging sub-second delay values.
The sender address of postmaster notifications that are
generated by the mail system.
The time limit for sending or receiving information over an
internal communication channel.
The maximum amount of time that an idle Postfix daemon process
waits for an incoming connection before terminating voluntarily.
The maximal number of incoming connections that a Postfix daemon
process will service before terminating voluntarily.
notify_classes (resource, software)
The list of error classes that are reported to the postmaster.
The process ID of a Postfix command or daemon process.
The process name of a Postfix command or daemon process.
queue_directory (see 'postconf -d' output)
The location of the Postfix top-level queue directory.
The syslog facility of Postfix logging.
syslog_name (see 'postconf -d' output)
A prefix that is prepended to the process name in syslog
records, so that, for example, "smtpd" becomes "prefix/smtpd".
Available in Postfix 3.3 and later:
The master.cf service name of a Postfix daemon process.
qmgr(8), queue manager
bounce(8), delivery status reports
discard(8), Postfix discard delivery agent
postconf(5), configuration parameters
master(5), generic daemon options
master(8), process manager
postlogd(8), Postfix logging
syslogd(8), system logging
The Secure Mailer license must be distributed with this software.
IBM T.J. Watson Research
P.O. Box 704
Yorktown Heights, NY 10598, USA
111 8th Avenue
New York, NY 10011, USA