DragonFly On-Line Manual Pages
ETHERS(5) DragonFly File Formats Manual ETHERS(5)
ethers -- ethernet address database
The ethers database contains information regarding known 48-bit ethernet
addresses of hosts on an Internetwork. The data is stored in a file
called /etc/ethers in the following format:
Items are separated by any number of blanks and/or tab characters. A
``#'' at the start of a line indicates the beginning of a comment that
extends to the end of the line. A ``+'' at the start of a line will
cause the ethers(3) library functions to use data stored in the NIS(8)
ethers.byname and ethers.byaddr maps in addition to the data in the
An ethernet address is expressed in ASCII form as "x:x:x:x:x:x" where x
is a hexadecimal value between 0x00 and 0xFF. The address values should
be in network order. Hostnames specified in the /etc/ethers database
should correspond to entries in the hosts(5) file.
The ether_line() function in the standard C library can be used to break
individual lines in the /etc/ethers database into their individual compo-
nents: a binary Ethernet address stored as an ether_addr structure, and a
hostname stored as a character string.
/etc/ethers The ethers file resides in /etc.
The ethers format is based on the format used in SunOS 4.1.x.
DragonFly 3.5 April 12, 1995 DragonFly 3.5