DragonFly On-Line Manual Pages
FLUSH(8) DragonFly System Manager's Manual FLUSH(8)
flush - Postfix fast flush server
flush [generic Postfix daemon options]
The flush(8) server maintains a record of deferred mail by destination.
This information is used to improve the performance of the SMTP ETRN
request, and of its command-line equivalent, "sendmail -qR" or
"postqueue -f". This program expects to be run from the master(8)
The record is implemented as a per-destination logfile with as contents
the queue IDs of deferred mail. A logfile is append-only, and is
truncated when delivery is requested for the corresponding destination.
A destination is the part on the right-hand side of the right-most @ in
an email address.
Per-destination logfiles of deferred mail are maintained only for
eligible destinations. The list of eligible destinations is specified
with the fast_flush_domains configuration parameter, which defaults to
This server implements the following requests:
add sitename queueid
Inform the flush(8) server that the message with the specified
queue ID is queued for the specified destination.
Request delivery of mail that is queued for the specified
Request delivery of the specified deferred message.
Refresh non-empty per-destination logfiles that were not read in
$fast_flush_refresh_time hours, by simulating send requests (see
above) for the corresponding destinations.
Delete empty per-destination logfiles that were not updated in
This request completes in the background.
purge Do a refresh for all per-destination logfiles.
The flush(8) server is not security-sensitive. It does not talk to the
network, and it does not talk to local users. The fast flush server
can run chrooted at fixed low privilege.
Problems and transactions are logged to syslogd(8) or postlogd(8).
Fast flush logfiles are truncated only after a "send" request, not when
mail is actually delivered, and therefore can accumulate outdated or
redundant data. In order to maintain sanity, "refresh" must be executed
periodically. This can be automated with a suitable wakeup timer
setting in the master.cf configuration file.
Upon receipt of a request to deliver mail for an eligible destination,
the flush(8) server requests delivery of all messages that are listed
in that destination's logfile, regardless of the recipients of those
messages. This is not an issue for mail that is sent to a relay_domains
destination because such mail typically only has recipients in one
Changes to main.cf are picked up automatically as flush(8) processes
run for only a limited amount of time. Use the command "postfix reload"
to speed up a change.
The text below provides only a parameter summary. See postconf(5) for
more details including examples.
config_directory (see 'postconf -d' output)
The default location of the Postfix main.cf and master.cf
How much time a Postfix daemon process may take to handle a
request before it is terminated by a built-in watchdog timer.
Optional list of destinations that are eligible for
per-destination logfiles with mail that is queued to those
The time after which a non-empty but unread per-destination
"fast flush" logfile needs to be refreshed.
The time after which an empty per-destination "fast flush"
logfile is deleted.
The time limit for sending or receiving information over an
internal communication channel.
The maximum amount of time that an idle Postfix daemon process
waits for an incoming connection before terminating voluntarily.
The maximal number of incoming connections that a Postfix daemon
process will service before terminating voluntarily.
parent_domain_matches_subdomains (see 'postconf -d' output)
A list of Postfix features where the pattern "example.com" also
matches subdomains of example.com, instead of requiring an
explicit ".example.com" pattern.
The process ID of a Postfix command or daemon process.
The process name of a Postfix command or daemon process.
queue_directory (see 'postconf -d' output)
The location of the Postfix top-level queue directory.
The syslog facility of Postfix logging.
syslog_name (see 'postconf -d' output)
A prefix that is prepended to the process name in syslog
records, so that, for example, "smtpd" becomes "prefix/smtpd".
Available in Postfix 3.3 and later:
The master.cf service name of a Postfix daemon process.
/var/spool/postfix/flush, "fast flush" logfiles.
smtpd(8), SMTP server
qmgr(8), queue manager
postconf(5), configuration parameters
master(5), generic daemon options
master(8), process manager
postlogd(8), Postfix logging
syslogd(8), system logging
Use "postconf readme_directory" or "postconf html_directory" to locate
ETRN_README, Postfix ETRN howto
The Secure Mailer license must be distributed with this software.
This service was introduced with Postfix version 1.0.
IBM T.J. Watson Research
P.O. Box 704
Yorktown Heights, NY 10598, USA
111 8th Avenue
New York, NY 10011, USA
flush(n) Tcl Built-In Commands flush(n)
flush - Flush buffered output for a channel
Flushes any output that has been buffered for channelId.
ChannelId must be an identifier for an open channel such as a Tcl
standard channel (stdout or stderr), the return value from an
invocation of open or socket, or the result of a channel creation
command provided by a Tcl extension. The channel must have been opened
If the channel is in blocking mode the command does not return until
all the buffered output has been flushed to the channel. If the channel
is in nonblocking mode, the command may return before all buffered
output has been flushed; the remainder will be flushed in the
background as fast as the underlying file or device is able to absorb
Prompt for the user to type some information in on the console:
puts -nonewline "Please type your name: "
gets stdin name
puts "Hello there, $name!"
file(n), open(n), socket(n), Tcl_StandardChannels(3)
blocking, buffer, channel, flush, nonblocking, output
Tcl 7.5 flush(n)