DragonFly On-Line Manual Pages
FSCK_MSDOSFS(8) DragonFly System Manager's Manual FSCK_MSDOSFS(8)
fsck_msdosfs - DOS/Windows (FAT) file system consistency checker
fsck_msdosfs -p [-f] filesystem ...
fsck_msdosfs [-fMny] filesystem ...
The fsck_msdosfs utility verifies and repairs FAT file systems (more
commonly known as DOS file systems).
The first form of fsck_msdosfs preens the specified file systems. It is
normally started by fsck(8) run from /etc/rc during automatic reboot,
when a FAT file system is detected. When preening file systems,
fsck_msdosfs will fix common inconsistencies non-interactively. If more
serious problems are found, fsck_msdosfs does not try to fix them,
indicates that it was not successful, and exits.
The second form of fsck_msdosfs checks the specified file systems and
tries to repair all detected inconsistencies, requesting confirmation
before making any changes.
The options are as follows:
-F Compatibility with the wrapper fsck(8) which seeks to determine
whether the file system needs to be cleaned immediately in
foreground, or if its cleaning can be deferred to background.
FAT (MS-DOS) file systems must always be cleaned in the
foreground. A non-zero exit code is always returned for this
-M Causes fsck_msdosfs to not use mmap(2) when checking a FAT32 file
system. This option is mainly for debugging purposes and is not
normally necessary. The fsck_msdosfs utility will automatically
fall back to use a simple LRU cache of 4 MiB when it failed to
perform mmap(2), or when -M is specified.
-f This option is ignored by fsck_msdosfs, and is present only for
compatibility with programs that check other file system types
for consistency, such as fsck_ffs(8).
-n Causes fsck_msdosfs to assume "no" as the answer to all operator
questions, except "CONTINUE?".
-p Preen the specified file systems.
-y Causes fsck_msdosfs to assume "yes" as the answer to all operator
fsck(8), fsck_ffs(8), mount_msdos(8)
The fsck_msdosfs utility appeared in NetBSD 1.2. fsck_msdosfs first
appeared in FreeBSD 4.4.
The fsck_msdosfs utility is currently under development.
DragonFly 5.7-DEVELOPMENT February 6, 2020 DragonFly 5.7-DEVELOPMENT