DragonFly On-Line Manual Pages
GIFCONFIG(8) DragonFly System Manager's Manual GIFCONFIG(8)
gifconfig -- configure generic IP tunnel
gifconfig interface [af] [physsrc physdest]
gifconfig interface delete
The gifconfig utility configures the physical address for the generic IP
tunnel interface, such as "gif0". Argument physsrc and physdest are
interpreted as the outer source/destination address for encapsulating
IPv4/v6 header. Argument af specifies the address family for physsrc and
physdest. af can be inet or inet6, and will be treated as inet if
If a special argument delete is specified, gifconfig just deletes the
existing source and destination addresses on interface. If no outer
addresses are specified, this usage has no effect.
The gifconfig utility takes the following optional argument:
-a Display information associated with all gif(4) interfaces.
Please note that it is very easy to create infinite routing loop, when
you configure tunnel over same address family (e.g. IPv4-over-IPv4).
Each gif(4) interface is created at runtime using interface cloning.
This is most easily done with the ifconfig(8) create command or using the
gifconfig_<interface> variable in rc.conf(5).
The gifconfig utility exits 0 on success, and >0 if an error occurs.
If you would like to configure IPv6 over IPv4 (aka IPv6 in IPv4) tunnel
between 10.1.1.1 and 10.2.3.4, you should perform the following command:
# gifconfig gif0 inet 10.1.1.1 10.2.3.4
This is also possible to use IPv6 as outer proto, by replacing inet to
inet6, and IPv4 addresses to some appropriate IPv6 addresses in above
The gifconfig utility first appeared in WIDE Hydrangea IPv6 protocol
IPv6 and IPsec support based on the KAME Project (http://www.kame.net/)
stack was initially integrated into FreeBSD 4.0
DragonFly 4.3 May 17, 1998 DragonFly 4.3