DragonFly On-Line Manual Pages
HESIOD.CONF(5) DragonFly File Formats Manual HESIOD.CONF(5)
hesiod.conf - Configuration file for the Hesiod library
The file hesiod.conf determines the behavior of the Hesiod library.
Blank lines and lines beginning with a `#' character are ignored. All
other lines should be of the form variable = value, where the value
should be a single word. Possible variables and values are:
lhs Specifies the domain prefix used for Hesiod queries. In almost
all cases, you should specify ``lhs=.ns''. The default value if
you do not specify an lhs value is no domain prefix, which is
not compatible with most Hesiod domains.
rhs Specifies the default Hesiod domain; this value may be
overridden by the HES_DOMAIN environment variable. You must
specify an rhs line for the Hesiod library to work properly.
Specifies which DNS classes Hesiod should do lookups in.
Possible values are IN (the preferred class) and HS (the
deprecated class, still used by some sites). You may specify
both classes separated by a comma to try one class first and
then the other if no entry is available in the first class. The
default value of the classes variable is ``IN,HS''.
There default value for ``lhs'' should probably be more reasonable.
30 November 1996 HESIOD.CONF(5)