DragonFly On-Line Manual Pages
I915(4) DragonFly Kernel Interfaces Manual I915(4)
i915 - Driver for Intel i915 family integrated graphics chipsets
The i915 driver provides support for integrated graphics chips by Intel.
Please refer the Loader Tunables section in syscons(4) for more
information about how to make the console work with i915.
Tunables can be set at the loader(8) prompt before booting the kernel or
stored in loader.conf(5).
When non-zero, disable interrupt usage for DisplayPort AUX
channel. This option doesn't affect GPU models older than
Generation 5 (Ironlake). Can be used as a workaround in cases
where DisplayPort panel initialization is unreliable, which often
leaves a blank screen after the i915 module was loaded.
1 = don't use AUX IRQ, 0 = auto (default).
Enable PSR (panel self refresh), only relevant for Haswell and
Broadwell CPUs. 1 = enable, 0 = disable (default). To maximize
PSR usage, it can be beneficial to set hw.dri.vblank_offdelay
(see drm(4)) to a sufficiently low value (or -1), to minimize
vblank interrupt activity.
Override execlists usage on Broadwell IGPs (no effect on other
IGP models). Disabling execlists reverts to legacy ringbuffer
mode. -1 = auto (default), 0 = disable, 1 = enable
If display backlight level can be controlled by the GPU (which is often
the case in notebooks), the sysctl hw.backlight_level can be used to
adjust the backlight level. Permitted values are from 0 to the value of
The i915 driver was first available for Linux.
DragonFly 5.7-DEVELOPMENT October 9, 2019 DragonFly 5.7-DEVELOPMENT