DragonFly On-Line Manual Pages
IWM(4) DragonFly Kernel Interfaces Manual IWM(4)
NAME
iwm - Intel IEEE 802.11ac wireless network driver
SYNOPSIS
To compile this driver into the kernel, include the following lines in
your kernel configuration file:
device iwm
device pci
device wlan
You also need to select a firmware for your device. Use
device iwmfw
to include them all.
Alternatively, to load the driver as a module at boot time, place the
following lines in loader.conf(5):
if_iwm_load="YES"
iwm3160fw_load="YES"
iwm3168fw_load="YES"
iwm7260fw_load="YES"
iwm7265fw_load="YES"
iwm7265Dfw_load="YES"
iwm8000Cfw_load="YES"
iwm8265fw_load="YES"
iwm9000fw_load="YES"
iwm9260fw_load="YES"
DESCRIPTION
The iwm driver provides support for:
Intel Dual Band Wireless AC 3160
Intel Dual Band Wireless AC 3165
Intel Dual Band Wireless AC 3168
Intel Dual Band Wireless AC 7260
Intel Dual Band Wireless AC 7265
Intel Dual Band Wireless AC 8260
Intel Dual Band Wireless AC 8265
Intel Dual Band Wireless AC 9260
Intel Dual Band Wireless AC 9270
Intel Dual Band Wireless AC 946X
Intel Dual Band Wireless AC 9560
iwm supports station mode operation. Only one virtual interface may be
configured at any time. For more information on configuring this device,
see ifconfig(8).
This driver requires the firmware built with the iwmfw module to work.
LOADER TUNABLES
hw.iwm.msi.enable
By default, the driver will use MSI if it is supported. This
behavior can be turned off by setting this tunable to 0.
hw.iwm.power_scheme
Power management scheme: 1 = active, 2 = balanced (default), 3 =
low power
hw.iwm.lar.disable
Allows disabling LAR (Location Aware Regulatory) feature: 0 = LAR
enabled if available (default), 1 = LAR disabled
EXAMPLES
Join an existing BSS network (i.e., connect to an access point):
ifconfig wlan create wlandev iwm0 inet 192.168.0.20 \
netmask 0xffffff00
Join a specific BSS network with network name "my_net":
ifconfig wlan create wlandev iwm0 ssid my_net up
Join a specific BSS network with 64-bit WEP encryption:
ifconfig wlan create wlandev iwm0 ssid my_net \
wepmode on wepkey 0x1234567890 weptxkey 1 up
Join a specific BSS network with 128-bit WEP encryption:
ifconfig wlan create wlandev iwm0 wlanmode adhoc ssid my_net \
wepmode on wepkey 0x01020304050607080910111213 weptxkey 1
DIAGNOSTICS
iwm%d: device timeout The driver will reset the hardware. This should
not happen.
iwm%d: firmware error The onboard microcontroller crashed for some
reason. The driver will reset the hardware. This should not happen.
iwm%d: fw chunk addr 0x%x len %d failed to load Timed out waiting for a
segment of the firmware to load. This should not happen.
iwm%d: could not read firmware %s (error %d) The driver failed to load
the firmware image using the firmware(9) subsystem. Verify the iwmfw(4)
firmware module is present.
iwm%d: Failed to start INIT ucode: %d An attempt to upload the INIT
firmware image to the onboard microcontroller failed. This should not
happen.
iwm%d: could not load firmware An attempt to upload the REGULAR firmware
image to the onboard microcontroller failed. This should not happen.
SEE ALSO
iwmfw(4), pci(4), wlan(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4),
ifconfig(8), wpa_supplicant(8)
HISTORY
The iwm device driver first appeared in OpenBSD 5.7.
DragonFly 5.9-DEVELOPMENT March 20, 2020 DragonFly 5.9-DEVELOPMENT