DragonFly On-Line Manual Pages
KERNCONF(5) DragonFly File Formats Manual KERNCONF(5)
kernconf -- kernel configuration file
This manual page describes the structure of the kernel configuration
file. It is processed by config(8) to create a build environment where a
kernel may be built using make(1). See build(7) for information on how
to build kernels.
Each line starts with a keyword at the beginning of the line and is
followed by additional parameters. Long input lines may be broken into
shorter lines by starting the second and subsequent lines with a white
space character. Numbers are specified using C-style syntax. Blank
lines are ignored. The `#' character is interpreted as a comment and is
ignored along with everything that follows it on the same line.
The following keywords are recognized in a configuration file:
This system is to run on the CPU type name. Legal types are:
HAMMER_CPU (x86-64). More than one CPU type specification can
appear in a configuration file.
device name [at bus] [port num] [irq num] [drq num] [iomem num] [iosiz
num] [flags num]
Configures support for device name. Additional parameters may be
passed to specify I/O configuration settings (most often for
at specifies a bus to which the device is attached.
port specifies the start address of I/O ports to be used by the
irq specifies the number of ports used by the device.
drq is the interrupt line number to be used.
iomem specifies the physical memory address used by the device.
iosiz specifies the physical memory size used by the device.
flags sets various flag bits for the device.
Sets the kernel identification string to string.
The system is to run on the machine type name. This is a legacy
keyword, it is normally set to same value as machine_arch.
The system is to run on the machine architecture name.
Currently, the only legal architecture is x86_64.
Defines a make(1) macro name with the value value in the kernel
Set the maxusers variable in the kernel.
Sets the option name. Some options expect to be assigned a
value, which may be an integer, a double-quoted word, a bare
word, or an empty string (""). Note that those are eventually
handled by the C compiler, so the rules of that language apply.
Sets the platform of this kernel to name. Legal platforms are
pc64 (64 bit AMD architecture), and vkernel64 (64 bit virtual
pseudo-device name [N]
Includes support for the pseudo-device name. Some pseudo-devices
can have multiple or N instances.
/sys/config/LINT64 kernel configuration file for checking all
the sources, includes description of kernel
/sys/config/VKERNEL64 default 64 bit vkernel(7) kernel
/sys/config/X86_64_GENERIC default x86_64 kernel configuration file
make(1), build(7), vkernel(7), config(8)
The kernconf manual page first appeared in DragonFly 1.11.
DragonFly 4.3 June 20, 2015 DragonFly 4.3