DragonFly On-Line Manual Pages
LINPROCFS(5) DragonFly File Formats Manual LINPROCFS(5)
linprocfs -- Linux process file system
linproc /compat/linux/proc linprocfs rw 0 0
The Linux process file system, or linprocfs, emulates a subset of Linux'
process file system and is required for the complete operation of some
The linprocfs provides a two-level view of process space. At the highest
level, processes themselves are named, according to their process ids in
decimal, with no leading zeros. There is also a special node called self
which always refers to the process making the lookup request.
Each node is a directory which contains the following entries:
Each directory contains several files:
exe A reference to the vnode from which the process text was read.
This can be used to gain access to the process' symbol table, or
to start another copy of the process.
mem The complete virtual memory image of the process. Only those
addresses which exist in the process can be accessed. Reads and
writes to this file modify the process. Writes to the text seg-
ment remain private to the process.
Each node is owned by the process's user, and belongs to that user's pri-
mary group, except for the mem node, which belongs to the kmem group.
/compat/linux/proc normal mount point for the linprocfs.
/compat/linux/proc/cpuinfo CPU vendor and model information in
/compat/linux/proc/meminfo System memory information in human-read-
/compat/linux/proc/pid directory containing process information
for process pid.
/compat/linux/proc/self directory containing process information
for the current process
/compat/linux/proc/self/exe executable image
/compat/linux/proc/self/mem the complete virtual address space of
mount(2), unmount(2), procfs(5), mount_linprocfs(8)
The linprocfs first appeared in FreeBSD 4.0.
The linprocfs was derived from procfs by Pierre Beyssac. This manual
page was written by Dag-Erling Smorgrav, based on the procfs(5) manual
page by Garrett Wollman.
DragonFly 4.7 August 10, 1994 DragonFly 4.7