DragonFly On-Line Manual Pages
LO(4) DragonFly Kernel Interfaces Manual LO(4)
lo -- software loopback network interface
The loop interface is a software loopback mechanism which may be used for
performance analysis, software testing, and/or local communication. As
with other network interfaces, the loopback interface must have network
addresses assigned for each address family with which it is to be used.
These addresses may be set or changed with the SIOCSIFADDR ioctl(2). The
loopback interface should be the last interface configured, as protocols
may use the order of configuration as an indication of priority. The
loopback should never be configured first unless no hardware interfaces
lo%d: can't handle af%d. The interface was handed a message with
addresses formatted in an unsuitable address family; the packet was
The lo device appeared in 4.2BSD.
Previous versions of the system enabled the loopback interface automati-
cally, using a nonstandard Internet address (127.1). Use of that address
is now discouraged; a reserved host address for the local network should
be used instead.
DragonFly 3.5 June 5, 1993 DragonFly 3.5