DragonFly On-Line Manual Pages
NDISGEN(8) DragonFly System Manager's Manual NDISGEN(8)
ndisgen -- generate a DragonFly driver module from a Windows(R) NDIS
ndisgen [/path/to/INF /path/to/SYS]
The ndisgen script uses the ndiscvt(8) utility and other tools to gener-
ate a DragonFly loadable driver module and a static ELF object module
from a Windows(R) NDIS driver, for use with the ndis(4) compatibility
The ndisgen script is interactive and contains its own help section.
Unless the paths to both files are supplied on the command line, the
script will prompt the user for the .INF and .SYS files needed to gener-
ate the DragonFly driver module. The script will also prompt for any
firmware or other external files needed.
ld(1), objcopy(1), ndis(4), kldload(8), ndiscvt(8)
The ndisgen utility first appeared in FreeBSD 6.0.
The ndisgen utility was written by Bill Paul <email@example.com>.
DragonFly 5.5 May 10, 2011 DragonFly 5.5