DragonFly On-Line Manual Pages
NVMM(4) DragonFly Kernel Interfaces Manual NVMM(4)
nvmm - Lightweight Hypervisor
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The nvmm driver provides kernel support for hardware-accelerated
virtualization. It is made of a generic MI frontend, to which MD
backends can be plugged to implement the core virtualization.
In practice, nvmm is used by the libnvmm(3) API to implement hypervisors.
The following backends are supported:
- x86-SVM, for x86 AMD CPUs
- x86-VMX, for x86 Intel CPUs
nvmm first appeared in NetBSD 9, and was ported to DragonFly 6.1.
The nvmm driver was written by Maxime Villard.
DragonFly 6.1-DEVELOPMENT July 29, 2021 DragonFly 6.1-DEVELOPMENT