DragonFly On-Line Manual Pages
PICKUP(8) DragonFly System Manager's Manual PICKUP(8)
pickup - Postfix local mail pickup
pickup [generic Postfix daemon options]
The pickup(8) daemon waits for hints that new mail has been dropped
into the maildrop directory, and feeds it into the cleanup(8) daemon.
Ill-formatted files are deleted without notifying the originator. This
program expects to be run from the master(8) process manager.
None. The pickup(8) daemon does not interact with the outside world.
The pickup(8) daemon is moderately security sensitive. It runs with
fixed low privilege and can run in a chrooted environment. However,
the program reads files from potentially hostile users. The pickup(8)
daemon opens no files for writing, is careful about what files it opens
for reading, and does not actually touch any data that is sent to its
public service endpoint.
Problems and transactions are logged to syslogd(8) or postlogd(8).
The pickup(8) daemon copies mail from file to the cleanup(8) daemon.
It could avoid message copying overhead by sending a file descriptor
instead of file data, but then the already complex cleanup(8) daemon
would have to deal with unfiltered user data.
As the pickup(8) daemon is a relatively long-running process, up to an
hour may pass before a main.cf change takes effect. Use the command
"postfix reload" command to speed up a change.
The text below provides only a parameter summary. See postconf(5) for
more details including examples.
CONTENT INSPECTION CONTROLS
After the message is queued, send the entire message to the
Enable or disable recipient validation, built-in content
filtering, or address mapping.
config_directory (see 'postconf -d' output)
The default location of the Postfix main.cf and master.cf
The time limit for sending or receiving information over an
internal communication channel.
Upon input, long lines are chopped up into pieces of at most
this length; upon delivery, long lines are reconstructed.
The maximum amount of time that an idle Postfix daemon process
waits for an incoming connection before terminating voluntarily.
The maximal number of incoming connections that a Postfix daemon
process will service before terminating voluntarily.
The process ID of a Postfix command or daemon process.
The process name of a Postfix command or daemon process.
queue_directory (see 'postconf -d' output)
The location of the Postfix top-level queue directory.
The syslog facility of Postfix logging.
syslog_name (see 'postconf -d' output)
A prefix that is prepended to the process name in syslog
records, so that, for example, "smtpd" becomes "prefix/smtpd".
Available in Postfix 3.3 and later:
The master.cf service name of a Postfix daemon process.
Available in Postfix 3.5 and later:
The email address form that will be used in non-debug logging
(info, warning, etc.).
cleanup(8), message canonicalization
sendmail(1), Sendmail-compatible interface
postdrop(1), mail posting agent
postconf(5), configuration parameters
master(5), generic daemon options
master(8), process manager
postlogd(8), Postfix logging
syslogd(8), system logging
The Secure Mailer license must be distributed with this software.
IBM T.J. Watson Research
P.O. Box 704
Yorktown Heights, NY 10598, USA
111 8th Avenue
New York, NY 10011, USA