DragonFly On-Line Manual Pages
PVSCSI(4) DragonFly Kernel Interfaces Manual PVSCSI(4)
pvscsi - VMware Paravirtual SCSI Controller
To compile this driver into the kernel, place the following line in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The following tunables are settable from the loader(8):
controls how many pages are allocated for the device request ring. A
non-positive value will cause the driver to choose the value based on
device capabilities. A non-zero value will use that many number of pages
up to a maximum of 32. The default setting is 0.
controls the queue size for the adapter. A non-positive value will cause
the driver to choose the value based on number of request ring pages. A
non-zero value will set the queue size up to a maximum allowed by the
number of request ring pages. Default is 0.
setting to nonzero value enables the use of the PVSCSI message queue
allowing for disk hot-add and remove without manual rescan needed.
Default is 1.
setting to nonzero value enables the use of MSI interrupts. Default is
setting to nonzero value enables the request call threshold
functionality. TODO. Default is 1.
The pvscsi driver provides support for the VMware Paravirtual SCSI
Controller (PVSCSI) in virtual machines by VMware.
The pvscsi driver first appeared in FreeBSD 13.0.
Vishal Bhakta <email@example.com>.
DragonFly 6.5-DEVELOPMENT February 27, 2023 DragonFly 6.5-DEVELOPMENT