DragonFly On-Line Manual Pages
RADEON(4) DragonFly Kernel Interfaces Manual RADEON(4)
radeon - Driver for AMD/ATI Radeon graphics chipsets
The radeon driver provides support for the AMD Radeon graphics chips.
Please refer the Loader Tunables section in syscons(4) for more
information about how to make the console work with radeon.
Tunables can be set at the loader(8) prompt before booting the kernel or
stored in loader.conf(5).
Disables AGP writeback for scratch registers.
Enable/Disable dynamic clocks
Enable/Disable MSI (message signaled interrupts) 1 = enable, 0 =
disable, -1 = auto (default)
Direct FB access for IGP chips, which can significantly improve
performance for some applications. This option only affects the
RS690, RS780 and RS880 chipsets, and only when no sideport memory
is available. 1 = enable, 0 = disable (default)
DPM (dynamic power management) support. 1 = enable, 0 = disable,
-1 = auto (default)
Backlight support. 1 = enable, 0 = disable, -1 = auto (default)
If display backlight level can be controlled by the GPU (which is often
the case in notebooks), the sysctl hw.backlight_level can be used to
adjust the backlight level. Permitted values are from 0 to the value
returned from the hw.backlight_max sysctl. On older Radeon GPU models
than the R600 series, the hw.backlight_level and hw.backlight_max sysctl
variables are no longer available by default. Setting the
drm.radeon.backlight tunable to "1" will force-enable native backlight
control via the sysctl variables in this case.
The radeon driver was first available for Linux.
Enabling drm.radeon.fastfb on RS690 chipsets can cause graphics
corruption when hardware acceleration is used. Display backlight control
with the hw.backlight_level sysctl is only supported for chipsets using
AtomBIOS (which includes some R400 chipsets and all later generations).
DragonFly 5.7-DEVELOPMENT October 9, 2019 DragonFly 5.7-DEVELOPMENT