DragonFly On-Line Manual Pages
RDRAND(4) DragonFly Kernel Interfaces Manual RDRAND(4)
rdrand -- driver for the RNG module on Intel CPUs
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
WARNING: This driver is still untested.
Starting with some models of the Ivy Bridge Core i5/i7, Intel processors
implement a new set of instructions called RdRand. This set of instruc-
tions uses a hardware based RNG providing high-speed true randomness.
The processor capability is reported as RDRND in the Features2 line at
boot. The rdrand driver does not attach on systems that lack the
required CPU capability.
The rdrand driver continuously feeds entropy to the kernel's random num-
intro(4), padlock(4), random(4)
The rdrand driver first appeared in DragonFly 3.1.
The rdrand driver was written by Alex Hornung <email@example.com>.
DragonFly 3.5 February 25, 2012 DragonFly 3.5