DragonFly On-Line Manual Pages
SAVECORE(8) DragonFly System Manager's Manual SAVECORE(8)
savecore -- save a core dump of the operating system
savecore -C [-v] [directory device]
savecore [-fkvz] [directory [device ...]]
The savecore utility copies the currently running kernel and its associ-
ated core dump into directory, or the current working directory if no
directory argument is given, and enters a reboot message and information
about the core dump into the system log.
The options are as follows:
-C Check to see if a dump exists, and display a brief message to
indicate the status. An exit status of 0 indicates that a dump
is there, 1 indicates that none exists. This option is compati-
ble only with the [-v] option.
-c Clear the dump, so that future invocations of savecore will
-f Force a dump to be taken even if either the dump was cleared or
if the dump header information is inconsistent.
-k Do not clear the dump after saving it.
-v Print out some additional debugging information.
-z Compress the core dump and kernel (see gzip(1)).
The savecore utility looks for dumps on each device specified by the
device argument(s), or on each device in /etc/fstab marked as ``dump'' or
``swap''. The savecore utility checks the core dump in various ways to
make sure that it is complete. If it passes these checks, it saves the
core image in directory/vmcore.# and the system in directory/kernel.# and
information about the core in directory/info.# The ``#'' is the number
from the first line of the file directory/bounds, and it is incremented
and stored back into the file each time savecore successfully runs.
The savecore utility also checks the available disk space before attempt-
ing to make the copies. If there is insufficient disk space in the
filesystem containing directory, or if the file directory/minfree exists
and the number of free kilobytes (for non-superusers) in the filesystem
after the copies were made would be less than the number in the first
line of this file, the copies are not attempted.
If savecore successfully copies the kernel and the core dump, the core
dump is cleared so that future invocations of savecore will ignore it.
The savecore utility is meant to be called near the end of the initial-
ization file /etc/rc (see rc(8)).
gzip(1), getbootfile(3), dumpon(8), loader(8), syslogd(8)
The savecore utility appeared in 4.1BSD.
The minfree code does not consider the effect of compression or sparse
DragonFly 3.5 December 15, 2009 DragonFly 3.5