DragonFly On-Line Manual Pages
SND_ES137X(4) DragonFly Kernel Interfaces Manual SND_ES137X(4)
snd_es137x -- Ensoniq AudioPCI ES137x bridge device driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The snd_es137x bridge driver allows the generic audio driver sound(4) to
attach to the Ensoniq 137x audio cards.
The following sysctl(8) variables are available in addition to those
available to all sound(4) devices:
hw.snd.pcm%d.latency_timer Controls the PCI latency timer setting.
Increasing this value will solve most
popping and crackling issues
(especially on VIA motherboards).
hw.snd.pcm%d.spdif_enabled Enables S/PDIF output on the primary
playback channel. This sysctl(8)
variable is available only if the
device is known to support S/PDIF
dev.pcm.%d.polling Experimental polling mode, where the
driver operates by querying the device
state on each tick using callout(9).
Polling is disabled by default. Do not
enable it unless you are facing weird
interrupt problems or if the device
cannot generate interrupts at all.
The snd_es137x driver supports the following sound cards:
o Creative CT5880-A
o Creative CT5880-C
o Creative CT5880-D
o Creative CT5880-E
o Creative SB AudioPCI CT4730
o Ensoniq AudioPCI ES1370
o Ensoniq AudioPCI ES1371-A
o Ensoniq AudioPCI ES1371-B
o Ensoniq AudioPCI ES1373-A
o Ensoniq AudioPCI ES1373-B
o Ensoniq AudioPCI ES1373-8
The snd_es137x device driver first appeared in FreeBSD 4.0.
Russell Cattelan <firstname.lastname@example.org>
Cameron Grant <cg@FreeBSD.org>
Jonathan Noack <email@example.com>
DragonFly 4.1 January 8, 2015 DragonFly 4.1