DragonFly On-Line Manual Pages
SND_UAUDIO(4) DragonFly Kernel Interfaces Manual SND_UAUDIO(4)
snd_uaudio -- USB audio and MIDI device driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The snd_uaudio driver provides support for USB audio class devices and
USB MIDI class devices.
A USB audio device consists of a number of components: input terminals
(e.g. USB digital input), output terminals (e.g. speakers), and a number
of units in between (e.g. volume control).
Refer to the `USB Audio Class Specification' for more information.
USB Audio Class Specifications,
The snd_uaudio driver first appeared in FreeBSD 4.7.
This manual page was adopted from NetBSD 1.6 and modified for FreeBSD by
Hiten Pandya <hmp@FreeBSD.org>.
The PCM framework in FreeBSD, as of this writing, does not handle device
un-registrations in a properly abstracted manner, i.e., a detach request
is refused by the PCM framework if the device is in use. It is necessary
to allow the device un-registration to complete successfully, otherwise
the PCM layer will panic.
DragonFly 4.1 January 8, 2015 DragonFly 4.1