DragonFly On-Line Manual Pages
SND_VIA8233(4) DragonFly Kernel Interfaces Manual SND_VIA8233(4)
snd_via8233 -- VIA Technologies VT8233 bridge device driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The snd_via8233 bridge driver allows the generic audio driver, sound(4),
to attach to the VIA VT8233 audio devices. These audio chipsets are
integrated in the southbridge on many VIA based motherboards.
The following sysctl(8) variables are available in addition to those
available to all sound(4) devices:
dev.pcm.%d.polling Experimental polling mode, where the driver
operates by querying the device state on each
tick using callout(9). Polling is disabled by
default. Do not enable it unless you are
facing weird interrupt problems or if the
device cannot generate interrupts at all.
The snd_via8233 driver supports the following audio chipsets:
o VIA VT8233
o VIA VT8233A
o VIA VT8233C
o VIA VT8235
o VIA VT8237
o VIA VT8251
The snd_via8233 device driver first appeared in FreeBSD 4.7.
This manual page was written by Joel Dahl <joel@FreeBSD.org>.
The snd_via8233 driver does not support S/PDIF. There is partial support
in the code, so implementing it should be fairly easy if the right
hardware is available.
DragonFly 4.1 January 8, 2015 DragonFly 4.1