DragonFly On-Line Manual Pages
TZSETUP(8) DragonFly System Manager's Manual TZSETUP(8)
tzsetup - set local timezone
tzsetup [-nrs] [-C chroot_directory] [zoneinfo_file | zoneinfo_name]
The tzsetup utility reads a database of timezone information and presents
a menu allowing the user to select a specific zone without knowing the
details of the database layout. The selected zone is installed as the
system default zone. The tzsetup utility also determines whether any
adjustment is necessary for systems where the hardware clock does not
The following options are available:
Open all files and directories relative to
-n Do not create or copy files.
-r Reinstall the zoneinfo file installed last time. The
name is obtained from /var/db/zoneinfo.
-s Skip the initial question about adjusting the clock if
not set to UTC.
It is possible to short-circuit the menu system by specifying the
location of a zoneinfo_file or the name of the zoneinfo_name on the
command line; this is intended mainly for pre-configured installation
scripts or people who know which zoneinfo they want to install.
The contents of the timezone database are indexed by
/usr/share/zoneinfo/zone.tab. This file lists, for each timezone data
file, the ISO 3166 territory code, approximate geographical coordinates
(in ISO 6709 format), and location within the territory.
The maintainers of the database maintain the following policies:
1. At least one zone for every country or inhabited geographical
2. One zone for every distinct, documented timezone history since
the beginning of the UNIX epoch (January 1, 1970, GMT).
3. Each zone is named for the most populous city therein. (Where
possible, the database includes pre-1970 history for its
The source code to the database (/usr/src/share/zoneinfo/[a-z]*) contains
many additional comments and documentation references for the
/etc/localtime current time zone file
/etc/wall_cmos_clock see adjkerntz(8)
/usr/share/misc/iso3166 mapping of ISO 3166 territory codes to
/usr/share/zoneinfo directory for zoneinfo files
/usr/share/zoneinfo/zone.tab mapping of timezone file to country and
/var/db/zoneinfo saved name of the timezone file
Normal usage, to select the right zoneinfo file via the dialog-based user
Install the file /usr/share/zoneinfo/Australia/Sydney:
Install the zoneinfo file for Australia/Sydney, assumed to be located in
After a reinstall of the zoneinfo files, you can reinstall the latest
installed zoneinfo file (as specified in /var/db/zoneinfo):
date(1), adjtime(2), ctime(3), tzfile(5), adjkerntz(8), zdump(8), zic(8)
The representation of certain localities as being associated with certain
countries and/or territories is for the purposes of identification only,
and does not imply any endorsement or rejection on the part of the
DragonFly Project of the territorial claims of any entity.
Programs which are already running when tzsetup creates or updates
/etc/localtime will not reflect the updated timezone. When the system is
first configured for a non-UTC hardware clock, it is necessary to run
adjkerntz(8) (which normally happens as a part of system startup) in
order to update the kernel's idea of the correct timezone offset.
DragonFly 5.9-DEVELOPMENT February 14, 2013 DragonFly 5.9-DEVELOPMENT