DragonFly On-Line Manual Pages
VGA(4) DragonFly Kernel Interfaces Manual VGA(4)
vga - generic video card interface
device vga0 at isa? port ?
The vga driver is a generic video card driver which provides access to
video cards. This driver is required for the syscons(4) console driver
which will call the vga driver to manipulate video hardware (changing
video modes, loading fonts, etc).
The vga driver supports the standard VGA video cards.
The following kernel configuration options can be used to control the vga
driver. These options provide compatibility with certain VGA cards.
VGA_DEBUG=N Set the VGA support debug level to N. The
default value is 0, which suppresses all
debugging output. A value of 2 gives maximum
VGA_KEEP_POWERON_MODE This option keeps the initial mode's register
settings for switching back to it from another
VGA_WIDTH90 This option enables 90 column modes: 90x25,
90x30, 90x43, 90x50, 90x60. These modes are
not always supported by the video card and the
display. It is highly likely that LCD display
cannot work with these modes.
The following option will remove some features from the vga driver and
save kernel memory.
VGA_NO_FONT_LOADING This option removes font loading from the
driver. Note that if you use this option and
still wish to use the mouse on the console
then you must also use the SC_ALT_MOUSE_IMAGE
option. See syscons(4).
VGA_NO_MODE_CHANGE This option prevents the driver from changing
Apple, IBM, Motorola, "Common Hardware Reference Platform: I/O Device
Reference", Appendix A: VGA Programming Model,
ftp://ftp.software.ibm.com/rs6000/technology/spec/chrp/, p. 195.
The vga driver first appeared in FreeBSD 3.1.
The vga driver was written by Soren Schmidt <sos@FreeBSD.org> and
Kazutaka Yokota <yokota@FreeBSD.org>. This manual page was written by
DragonFly 5.9-DEVELOPMENT March 3, 2020 DragonFly 5.9-DEVELOPMENT