DragonFly On-Line Manual Pages
VIRTIO_BLK(4) DragonFly Kernel Interfaces Manual VIRTIO_BLK(4)
virtio_blk -- VirtIO Block driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The virtio_blk device driver provides support for VirtIO block devices.
/dev/vbdX virtio_blk device nodes
Tunables can be set at the loader(8) prompt before booting the kernel or
stored in loader.conf(5).
These tunables determine the write cache mode globally or per-
device. The mode can changed only if the ConfigWCE feature is
negotiated. Set to 0 for writethrough mode, 1 for writeback
mode, and -1 to leave it as-is. The default value is to leave
The following variables are available as sysctl(8) variables.
The write cache mode of the device can be either writethrough (0)
or writeback (1). If the ConfigWCE feature is negotiated, the
write cache mode can be toggled between writethrough and
The virtio_blk driver was written by Bryan Venteicher
<bryanv@FreeBSD.org>. It first appeared in FreeBSD 9.0.
DragonFly 4.1 December 10, 2014 DragonFly 4.1