DragonFly On-Line Manual Pages
WPI(4) DragonFly Kernel Interfaces Manual WPI(4)
wpi -- Intel 3945ABG Wireless LAN IEEE 802.11 driver
To compile this driver into the kernel, place the following lines in your
kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The wpi driver provides support for the Intel 3945ABG Wireless network
adapter. wpi supports station, adhoc, and monitor mode operation. Only
one virtual interface may be configured at any time. For more
information on configuring this device, see ifconfig(8).
This driver requires the firmware built with the wpifw module to work.
/usr/share/doc/legal/intel_wpi/LICENSE wpi firmware license
Join an existing BSS network (i.e., connect to an access point):
ifconfig wlan0 create wlandev wpi0 inet 192.168.0.20 \
Join a specific BSS network with network name ``my_net'':
ifconfig wlan0 create wlandev wpi0 ssid my_net up
Join a specific BSS network with 64-bit WEP encryption:
ifconfig wlan0 create wlandev wpi0 ssid my_net \
wepmode on wepkey 0x1234567890 weptxkey 1 up
Join a specific BSS network with 128-bit WEP encryption:
ifconfig wlan0 create wlandev wpi0 wlanmode adhoc ssid my_net \
wepmode on wepkey 0x01020304050607080910111213 weptxkey 1
wpi%d: could not load firmware image '%s' The driver failed to load the
firmware image using the firmware(9) subsystem. Verify the wpifw
firmware module is installed.
wpi%d: fatal firmware error An unknown error has occurred in the
uploaded firmware, you may have to unload/reload the driver to continue.
wpi%d: Radio transmitter is switched off The hardware switch controlling
the radio is currently turned off. Data transmission is not possible in
ifmedia(4), pci(4), wlan(4), wlan_ccmp(4), wlan_tkip(4), wlan_wep(4),
The original wpi driver was written for OpenBSD by Damien Bergamini
<firstname.lastname@example.org>. Benjamin Close <benjsc@FreeBSD.org> ported
wpi to FreeBSD.
Not all the error messages are documented here.
Background scanning is not currently supported.
DragonFly 4.5 May 26, 2016 DragonFly 4.5