DragonFly On-Line Manual Pages
WSP(4) DragonFly Kernel Interfaces Manual WSP(4)
wsp - Wellspring touchpad driver
To compile this driver into the kernel, place the following lines into
your kernel configuration file:
Alternatively, to load the driver as a module at boot time, place the
following line in loader.conf(5):
The wsp driver provides support for the Apple Internal Trackpad device
found in many Apple laptops.
The driver simulates a three-button mouse using multi-finger tap
detection. A single-finger press generates a left button click. A two-
finger tap maps to the right button; whereas a three-finger tap gets
treated as a middle button click.
wsp supports dynamic reconfiguration using sysctl(8) through nodes under
hw.usb.wsp. Pointer sensitivity can be controlled using the sysctl
tunable hw.usb.wsp.scale_factor. Tap to left-click can be controlled
using the sysctl tunable hw.usb.wsp.enable_single_tap_clicks, set to 0 to
disable single tap clicks or 1 to enable them (default).
wsp creates a blocking pseudo-device file, /dev/wsp0, which presents the
mouse as a sysmouse or mousesystems type device--see moused(8) for an
explanation of these mouse types.
sysmouse(4), usb(4), loader.conf(5), xorg.conf(5) (x11/xorg), moused(8),
The wsp driver was written by Huang Wen Hui <firstname.lastname@example.org>.
DragonFly 5.9-DEVELOPMENT July 9, 2020 DragonFly 5.9-DEVELOPMENT