DragonFly On-Line Manual Pages

Search: Section:  


DEVICE_ATTACH(9)      DragonFly Kernel Developer's Manual     DEVICE_ATTACH(9)

NAME

DEVICE_ATTACH -- attach a device

SYNOPSIS

#include <sys/param.h> #include <sys/bus.h> int DEVICE_ATTACH(device_t dev);

DESCRIPTION

Attach a device to the system. The probe method will have been called and will have indicated that the device exists. This routine should ini- tialise the hardware and allocate other system resources (such as /dev entries).

RETURN VALUES

Zero is returned on success, otherwise an appropriate error is returned.

SEE ALSO

device(9), DEVICE_DETACH(9), DEVICE_PROBE(9)

AUTHORS

This man page was written by Doug Rabson. DragonFly 3.5 June 16, 1998 DragonFly 3.5

Search: Section: